Bug 1248450 - rpc: check for unprivileged port should start at 1024 and not beyond 1024
rpc: check for unprivileged port should start at 1024 and not beyond 1024
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: rpc (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milind Changire
:
Depends On: 1248461 1247930
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 06:31 EDT by Milind Changire
Modified: 2015-09-09 05:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1247930
Environment:
Last Closed: 2015-09-09 05:38:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milind Changire 2015-07-30 06:31:28 EDT
+++ This bug was initially created as a clone of Bug #1247930 +++

Description of problem:
rpc/rpc-lib/src/rpcsvc.c::rpcsvc_handle_rpc_call()
check for unprivileged port > 1024 should be changed to port >= 1024


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-07-30 04:18:28 EDT ---

REVIEW: http://review.gluster.org/11788 (rpc: check for unprivileged port should start at 1024) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)

--- Additional comment from Anand Avati on 2015-07-30 06:30:14 EDT ---

REVIEW: http://review.gluster.org/11804 (rpc: check for unprivileged port should start at 1024) posted (#1) for review on release-3.7 by Milind Changire (mchangir@redhat.com)
Comment 1 Anand Avati 2015-08-13 02:06:48 EDT
REVIEW: http://review.gluster.org/11804 (rpc: check for unprivileged port should start at 1024) posted (#3) for review on release-3.7 by Raghavendra G (rgowdapp@redhat.com)
Comment 2 Anand Avati 2015-08-14 00:05:44 EDT
COMMIT: http://review.gluster.org/11804 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 0ab5623774151ba98e3ac65918e365d441713b04
Author: Milind Changire <mchangir@redhat.com>
Date:   Wed Jul 29 14:57:44 2015 +0530

    rpc: check for unprivileged port should start at 1024
    
    The current check for unprivileged port starts beyond 1024
    i.e. port > 1024
    The actual check should start at 1024
    i.e. port >= 1024
    
    Change-Id: I78aff3025891e3e78ca6a9a670c89571752157df
    BUG: 1248450
    Reviewed-on: http://review.gluster.org/#/c/11788/
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/11804
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 3 Kaushal 2015-09-09 05:38:53 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.