Bug 1247972 - quota/marker: lk_owner is null while acquiring inodelk in rename operation
quota/marker: lk_owner is null while acquiring inodelk in rename operation
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.6.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
:
Depends On: 1240598
Blocks: glusterfs-3.6.6
  Show dependency treegraph
 
Reported: 2015-07-29 07:13 EDT by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:48 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.6.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1240598
Environment:
Last Closed: 2015-09-30 08:15:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-07-29 07:13:17 EDT
+++ This bug was initially created as a clone of Bug #1240598 +++

Before doing a rename operation marker takes inode lock on the file parent,
here lk_owner is NULL and this can cause accounting problem with multiple rename on the same directory

--- Additional comment from Anand Avati on 2015-07-07 06:41:14 EDT ---

REVIEW: http://review.gluster.org/11561 (quota/marker: set lk_owner when taking lock on parent in rename) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-07-07 08:57:01 EDT ---

REVIEW: http://review.gluster.org/11561 (quota/marker: set lk_owner when taking lock on parent in rename) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-07-10 00:09:00 EDT ---

COMMIT: http://review.gluster.org/11561 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 7488acff20ef6ff8df76af07547695e0106f32ca
Author: vmallika <vmallika@redhat.com>
Date:   Tue Jul 7 16:03:26 2015 +0530

    quota/marker: set lk_owner when taking lock on parent in rename
    
    Before doing a rename operation marker takes inode lock on the file
    parent,
    here lk_owner is NULL and this can cause accounting problem with
    multiple rename on the same directory
    
    This patch fix the problem by setting lk_owner
    
    Change-Id: Ibb789e39b2833e425d0a5fca85282ff1465206cb
    BUG: 1240598
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11561
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 1 Anand Avati 2015-07-29 07:15:57 EDT
REVIEW: http://review.gluster.org/11795 (quota/marker: set lk_owner when taking lock on parent in rename) posted (#1) for review on release-3.6 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Anand Avati 2015-08-14 04:58:19 EDT
REVIEW: http://review.gluster.org/11795 (quota/marker: set lk_owner when taking lock on parent in rename) posted (#2) for review on release-3.6 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 3 Anand Avati 2015-08-19 03:28:23 EDT
REVIEW: http://review.gluster.org/11795 (quota/marker: set lk_owner when taking lock on parent in rename) posted (#3) for review on release-3.6 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 4 Anand Avati 2015-08-27 04:33:26 EDT
REVIEW: http://review.gluster.org/11795 (quota/marker: set lk_owner when taking lock on parent in rename) posted (#5) for review on release-3.6 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 5 Raghavendra Bhat 2015-09-21 02:50:08 EDT
http://review.gluster.org/#/c/11795/ has been merged.
Comment 6 Raghavendra Bhat 2015-09-30 08:15:13 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.6, please open a new bug report.

glusterfs-3.6.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-devel/2015-September/046821.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.