Bug 1240598 - quota/marker: lk_owner is null while acquiring inodelk in rename operation
Summary: quota/marker: lk_owner is null while acquiring inodelk in rename operation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1241048 1241487 1247972
TreeView+ depends on / blocked
 
Reported: 2015-07-07 10:33 UTC by Vijaikumar Mallikarjuna
Modified: 2016-06-16 13:20 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1241048 1241487 1247972 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:20:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijaikumar Mallikarjuna 2015-07-07 10:33:03 UTC
Before doing a rename operation marker takes inode lock on the file parent,
here lk_owner is NULL and this can cause accounting problem with multiple rename on the same directory

Comment 1 Anand Avati 2015-07-07 10:41:14 UTC
REVIEW: http://review.gluster.org/11561 (quota/marker: set lk_owner when taking lock on parent in rename) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2015-07-07 12:57:01 UTC
REVIEW: http://review.gluster.org/11561 (quota/marker: set lk_owner when taking lock on parent in rename) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Anand Avati 2015-07-10 04:09:00 UTC
COMMIT: http://review.gluster.org/11561 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 7488acff20ef6ff8df76af07547695e0106f32ca
Author: vmallika <vmallika@redhat.com>
Date:   Tue Jul 7 16:03:26 2015 +0530

    quota/marker: set lk_owner when taking lock on parent in rename
    
    Before doing a rename operation marker takes inode lock on the file
    parent,
    here lk_owner is NULL and this can cause accounting problem with
    multiple rename on the same directory
    
    This patch fix the problem by setting lk_owner
    
    Change-Id: Ibb789e39b2833e425d0a5fca85282ff1465206cb
    BUG: 1240598
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11561
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 4 Nagaprasad Sathyanarayana 2015-10-25 14:45:20 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 5 Niels de Vos 2016-06-16 13:20:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.