Bug 1248069 - Rebuild needed for RHEL6.7
Rebuild needed for RHEL6.7
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: php-pecl-imagick (Show other bugs)
el6
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
:
: 1249798 1249876 1251556 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 10:23 EDT by Matt Kynaston
Modified: 2016-04-29 02:15 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 05:50:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec for version 3.1.2 (5.64 KB, text/x-matlab)
2015-07-29 10:23 EDT, Matt Kynaston
no flags Details

  None (edit)
Description Matt Kynaston 2015-07-29 10:23:57 EDT
Created attachment 1057331 [details]
Spec for version 3.1.2

Description of problem:

RHEL6.7 contains an updated ImageMagick package, causing the install of php-pecl-imagick to fail.

Version-Release number of selected component (if applicable):

2.2.2-4

How reproducible:

Always

Steps to Reproduce:
1. yum update

Actual results:

Error: Package: php-pecl-imagick-2.2.2-4.el6.x86_64 (@epel)
Requires: libMagickCore.so.2()(64bit)

Expected results:

Package installs

Additional info:

Version 2.2.2 is pretty long in the tooth (2009). Attached is a version-bumped spec for the latest stable version (3.1.2)
Comment 1 Guillaume Belrose 2015-08-18 12:46:21 EDT
I just ran into this very same problem today while trying to install the Icinga Web 2 package on CentOS 6.6 (I followed the instructions at https://github.com/Icinga/icingaweb2/blob/master/doc/installation.md). 

Is there a workaround that I could apply in the meantime? I guess I could rebuild a new RPM based on the spec file posted by @matt.
Comment 2 JB 2015-08-18 12:59:04 EDT
(In reply to Guillaume Belrose from comment #1)
> Is there a workaround that I could apply in the meantime? I guess I could
> rebuild a new RPM based on the spec file posted by @matt.

I was able to work around the problem by removing ImageMagick (yum remove ImageMagick), then doing a yum update of everything (and thus going from CentOS 6.6 to 6.7), reboot (because of the new kernel), then yum install ImageMagick. No errors, went smoothly.
Comment 3 Guillaume Belrose 2015-08-18 13:41:42 EDT
(In reply to JB from comment #2)
> (In reply to Guillaume Belrose from comment #1)
> > Is there a workaround that I could apply in the meantime? I guess I could
> > rebuild a new RPM based on the spec file posted by @matt.
> 
> I was able to work around the problem by removing ImageMagick (yum remove
> ImageMagick), then doing a yum update of everything (and thus going from
> CentOS 6.6 to 6.7), reboot (because of the new kernel), then yum install
> ImageMagick. No errors, went smoothly.

I've done what you suggested, but the problem does not go away when trying to install php-pecl-imagick:

[vagrant@icinga ~]$ sudo yum install php-pecl-imagick-2.2.2-4.el6.x86_64
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.mhd.uk.as44574.net
 * epel: mirrors.coreix.net
 * extras: mirror.mhd.uk.as44574.net
 * updates: anorien.csc.warwick.ac.uk
Resolving Dependencies
--> Running transaction check
---> Package php-pecl-imagick.x86_64 0:2.2.2-4.el6 will be installed
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-imagick-2.2.2-4.el6.x86_64
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-imagick-2.2.2-4.el6.x86_64
--> Processing Dependency: /usr/bin/pecl for package: php-pecl-imagick-2.2.2-4.el6.x86_64
--> Processing Dependency: /usr/bin/pecl for package: php-pecl-imagick-2.2.2-4.el6.x86_64
--> Processing Dependency: libMagickWand.so.2()(64bit) for package: php-pecl-imagick-2.2.2-4.el6.x86_64
--> Processing Dependency: libMagickCore.so.2()(64bit) for package: php-pecl-imagick-2.2.2-4.el6.x86_64
--> Running transaction check
---> Package php-common.x86_64 0:5.3.3-46.el6_6 will be installed
---> Package php-pear.noarch 1:1.9.4-4.el6 will be installed
--> Processing Dependency: php-cli >= 5.1.0-1 for package: 1:php-pear-1.9.4-4.el6.noarch
---> Package php-pecl-imagick.x86_64 0:2.2.2-4.el6 will be installed
--> Processing Dependency: libMagickWand.so.2()(64bit) for package: php-pecl-imagick-2.2.2-4.el6.x86_64
--> Processing Dependency: libMagickCore.so.2()(64bit) for package: php-pecl-imagick-2.2.2-4.el6.x86_64
--> Running transaction check
---> Package php-cli.x86_64 0:5.3.3-46.el6_6 will be installed
---> Package php-pecl-imagick.x86_64 0:2.2.2-4.el6 will be installed
--> Processing Dependency: libMagickWand.so.2()(64bit) for package: php-pecl-imagick-2.2.2-4.el6.x86_64
--> Processing Dependency: libMagickCore.so.2()(64bit) for package: php-pecl-imagick-2.2.2-4.el6.x86_64
--> Finished Dependency Resolution
Error: Package: php-pecl-imagick-2.2.2-4.el6.x86_64 (epel)
           Requires: libMagickWand.so.2()(64bit)
Error: Package: php-pecl-imagick-2.2.2-4.el6.x86_64 (epel)
           Requires: libMagickCore.so.2()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 4 Guillaume Belrose 2015-08-19 02:13:33 EDT
Hi Matt, 

I've tried your Spec file and it worked for me (it also unblocks my icingaweb2 installation).

The only extra thing that I had to do was to add a file imagick.ini in the SOURCES folder of the rpmbuild directory.

The file has the following content: extension=imagick.so

Thanks, 

Guillaume.
 
(In reply to Matt Kynaston from comment #0)
> Created attachment 1057331 [details]
> Spec for version 3.1.2
> 
> Description of problem:
> 
> RHEL6.7 contains an updated ImageMagick package, causing the install of
> php-pecl-imagick to fail.
> 
> Version-Release number of selected component (if applicable):
> 
> 2.2.2-4
> 
> How reproducible:
> 
> Always
> 
> Steps to Reproduce:
> 1. yum update
> 
> Actual results:
> 
> Error: Package: php-pecl-imagick-2.2.2-4.el6.x86_64 (@epel)
> Requires: libMagickCore.so.2()(64bit)
> 
> Expected results:
> 
> Package installs
> 
> Additional info:
> 
> Version 2.2.2 is pretty long in the tooth (2009). Attached is a
> version-bumped spec for the latest stable version (3.1.2)
Comment 5 Peter Meier 2015-08-20 13:46:37 EDT
update in epel-testing looks good to me https://bodhi.fedoraproject.org/updates/php-pecl-imagick-2.2.2-5.el6
Comment 6 Matt Kynaston 2015-09-02 07:34:38 EDT
FYI, looks like php-pecl-imagick-2.2.2-5 has been pushed to stable now.
Comment 7 Tilman Mayer 2015-09-02 09:48:09 EDT
Thank you, I can confirm that it is working in our environment.
Comment 8 Pavel Alexeev 2015-12-03 14:51:55 EST
*** Bug 1249798 has been marked as a duplicate of this bug. ***
Comment 9 Pavel Alexeev 2015-12-04 13:34:40 EST
*** Bug 1249876 has been marked as a duplicate of this bug. ***
Comment 10 Pavel Alexeev 2015-12-08 15:45:47 EST
*** Bug 1251556 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.