Bug 1249798 - yum update fails for php-pecl-imagick
yum update fails for php-pecl-imagick
Status: CLOSED DUPLICATE of bug 1248069
Product: Fedora EPEL
Classification: Fedora
Component: php-pecl-imagick (Show other bugs)
el6
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 17:00 EDT by oirraza
Modified: 2015-12-03 14:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-03 14:51:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description oirraza 2015-08-03 17:00:45 EDT
Description of problem:

OS: RHEL 6.6

Attempt to update system with "yum update" command (updating from 6.6 to 6.7) fails complaining about php-pecl-imagick package.

# yum update
Loaded plugins: product-id, rhnplugin, subscription-manager
This system is not registered with RHN Classic or RHN Satellite.
You can use rhn_register to register.
RHN Satellite or RHN Classic support will be disabled.
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.5.4.7-7.el6_5 will be updated
--> Processing Dependency: libMagickCore.so.2()(64bit) for package: php-pecl-imagick-2.2.2-4.el6.x86_64
--> Processing Dependency: libMagickWand.so.2()(64bit) for package: php-pecl-imagick-2.2.2-4.el6.x86_64
---> Package ImageMagick.x86_64 0:6.7.2.7-2.el6 will be an update
--> Processing Dependency: libwmf-0.2.so.7()(64bit) for package: ImageMagick-6.7.2.7-2.el6.x86_64
---> Package ImageMagick-devel.x86_64 0:6.5.4.7-7.el6_5 will be updated
---> Package ImageMagick-devel.x86_64 0:6.7.2.7-2.el6 will be an update
---> Package ImageMagick-doc.x86_64 0:6.5.4.7-7.el6_5 will be updated
---> Package ImageMagick-doc.x86_64 0:6.7.2.7-2.el6 will be an update
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.5.4.7-7.el6_5 will be updated
--> Processing Dependency: libMagickCore.so.2()(64bit) for package: php-pecl-imagick-2.2.2-4.el6.x86_64
--> Processing Dependency: libMagickWand.so.2()(64bit) for package: php-pecl-imagick-2.2.2-4.el6.x86_64
---> Package libwmf.x86_64 0:0.2.8.4-23.el6 will be installed
--> Finished Dependency Resolution
Error: Package: php-pecl-imagick-2.2.2-4.el6.x86_64 (@epel)
           Requires: libMagickCore.so.2()(64bit)
           Removing: ImageMagick-6.5.4.7-7.el6_5.x86_64 (@rhel-x86_64-server-6)
               libMagickCore.so.2()(64bit)
           Updated By: ImageMagick-6.7.2.7-2.el6.x86_64 (rhel-6-server-rpms)
               Not found
           Available: ImageMagick-6.5.4.7-5.el6.x86_64 (rhel-6-server-rpms)
               libMagickCore.so.2()(64bit)
           Available: ImageMagick-6.5.4.7-6.el6_2.x86_64 (rhel-6-server-rpms)
               libMagickCore.so.2()(64bit)
Error: Package: php-pecl-imagick-2.2.2-4.el6.x86_64 (@epel)
           Requires: libMagickWand.so.2()(64bit)
           Removing: ImageMagick-6.5.4.7-7.el6_5.x86_64 (@rhel-x86_64-server-6)
               libMagickWand.so.2()(64bit)
           Updated By: ImageMagick-6.7.2.7-2.el6.x86_64 (rhel-6-server-rpms)
               Not found
           Available: ImageMagick-6.5.4.7-5.el6.x86_64 (rhel-6-server-rpms)
               libMagickWand.so.2()(64bit)
           Available: ImageMagick-6.5.4.7-6.el6_2.x86_64 (rhel-6-server-rpms)
               libMagickWand.so.2()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Pim Rupert (Lemonbit) 2015-08-09 08:22:01 EDT
Duplicate of Bug 1248069.
Comment 2 Pavel Alexeev 2015-12-03 14:51:55 EST

*** This bug has been marked as a duplicate of bug 1248069 ***
Comment 3 Pavel Alexeev 2015-12-03 14:53:49 EST
Thank you Pim.

Note You need to log in before you can comment on or make changes to this bug.