Bug 1248344 - SRPMs from Dropbox failing, same SRPM from Fedora repo succeeds
SRPMs from Dropbox failing, same SRPM from Fedora repo succeeds
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
: 1252343 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 03:17 EDT by coprgriever
Modified: 2015-10-07 00:06 EDT (History)
7 users (show)

See Also:
Fixed In Version: 1.2.13-2.fc22 mock-1.2.13-2.fc21 mock-1.2.13-2.el7 mock-1.2.13-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 00:09:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description coprgriever 2015-07-30 03:17:39 EDT
Description of problem:
SRPMs fail to build when using Dropbox as a file host. Tested mirroring official SRPMs on Dropbox and a few temporary file hosts; all fail to build.



How reproducible:
Attempt to build any SRPM using Dropbox as a file host.

Steps to Reproduce:
1. Attempt to build a SRPM from Dropbox using either frontend or cli

Actual results:
https://copr-be.cloud.fedoraproject.org/results/griever/misc/fedora-22-x86_64/copr-cli-1.44-1.fc22/prev_build_backup/

Expected results:
https://copr-be.cloud.fedoraproject.org/results/griever/misc/fedora-22-x86_64/copr-cli-1.44-1.fc22/

Additional info:
Let me know if you need anything else or are unable to reproduce. I've seen similar build failures on https://copr.fedoraproject.org/recent/, so I do not believe I am the only one experiencing the issue.
Comment 1 Miroslav Suchý 2015-07-30 05:13:31 EDT
Hmm it is strange. Dropbox emits header:
  Content-Disposition: inline; filename="copr-cli-1.44-1.fc22.src.rpm"; filename*=UTF-8''copr-cli-1.44-1.fc22.src.rpm
and therefore Copr takes
  copr-cli-1.44-1.fc22.src.rpm"; filename*=UTF-8''copr-cli-1.44-1.fc22.src.rpm
as filename.
This is not specified in RFC, however we should be probably able to parse it.

I am looking if there already exist some library for parsing content disposition header.
python-rfc6266 seems to be broken (bug 1248419).
Comment 2 Miroslav Suchý 2015-07-30 05:30:27 EDT
I used cgi module for parsing.

Fixed in mock.git in commit 466f066
Comment 3 Miroslav Suchý 2015-08-11 06:09:06 EDT
*** Bug 1252343 has been marked as a duplicate of this bug. ***
Comment 4 Severin Gehwolf 2015-08-11 07:15:21 EDT
Any ETA on when this gets submitted as an update?
Comment 5 Fedora Update System 2015-09-16 16:02:04 EDT
mock-1.2.13-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16053
Comment 6 Fedora Update System 2015-09-16 16:05:01 EDT
mock-1.2.13-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16054
Comment 7 Fedora Update System 2015-09-16 16:07:00 EDT
mock-1.2.13-2.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16056
Comment 8 Fedora Update System 2015-09-16 16:08:43 EDT
mock-1.2.13-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8114
Comment 9 Fedora Update System 2015-09-16 16:09:49 EDT
mock-1.2.13-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8115
Comment 10 Fedora Update System 2015-09-17 17:30:11 EDT
mock-1.2.13-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16054
Comment 11 Fedora Update System 2015-09-18 01:21:06 EDT
mock-1.2.13-2.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16056
Comment 12 Fedora Update System 2015-09-18 12:24:36 EDT
mock-1.2.13-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16053
Comment 13 Fedora Update System 2015-09-18 23:20:00 EDT
mock-1.2.13-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8115
Comment 14 Fedora Update System 2015-09-18 23:21:50 EDT
mock-1.2.13-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8114
Comment 15 Fedora Update System 2015-09-23 00:09:00 EDT
mock-1.2.13-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2015-09-24 04:22:45 EDT
mock-1.2.13-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2015-10-05 18:50:44 EDT
mock-1.2.13-2.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-10-06 23:05:12 EDT
mock-1.2.13-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2015-10-07 00:05:19 EDT
mock-1.2.13-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.