Bug 1252343 - Mockchain cannot download SRPMs from dropbox
Mockchain cannot download SRPMs from dropbox
Status: CLOSED DUPLICATE of bug 1248344
Product: Copr
Classification: Community
Component: backend (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Depends On:
  Show dependency treegraph
Reported: 2015-08-11 04:29 EDT by Severin Gehwolf
Modified: 2015-08-11 06:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-08-11 06:09:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Severin Gehwolf 2015-08-11 04:29:05 EDT
When trying to build from an SRPM hosted on dropbox copr builds fail with a weird error message:
[2015-08-07 13:19:21,547][ ERROR][PID:12267] builder.build error building pkg `https://dl.dropboxusercontent.com/s/6ib68tn3uoqf4f6/thermostat-1.99.5-4.fedora.src.rpm`: BuildError: rc 2 not in success_codes; return code: 2; stdout: starting logfile: None

An example build URL is here:

I've been told that this is due to an unknown problem in mockchain. Perhaps this is worth fixing? FWIW, I can download the SRPM via wget or curl just fine:

$ wget https://dl.dropboxusercontent.com/s/6ib68tn3uoqf4f6/thermostat-1.99.5-4.fedora.src.rpm

Note that in theory copr should be able to build from any publicly accessible URL. Doesn't seem like it in practice. It's also worth pointing out that we push those builds via a CI RPM builder which is automated and I rather use a shared dropbox account than copying a private SSH key to the builder in order to be able to use fedorapeople.org or some such for uploading the SRPM.

Bug 1045744 will somewhat help. However, it seems it's not yet fixed. Nevertheless, I think this should get investigated at least as to why it's failing to download from a shared dropbox URL.
Comment 1 Miroslav Suchý 2015-08-11 06:09:06 EDT

*** This bug has been marked as a duplicate of bug 1248344 ***
Comment 2 Miroslav Suchý 2015-08-11 06:11:52 EDT
Bug 1045744 is fixed in mock.git master. Once there is release and new version get into Fedora it will be automatically included in Copr infrastructure.

Note You need to log in before you can comment on or make changes to this bug.