Bug 1248377 - Stateless VM snapshot gets deleted when user shuts down VM in a Manual Pool type
Stateless VM snapshot gets deleted when user shuts down VM in a Manual Pool type
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.3
x86_64 Linux
high Severity high
: ovirt-3.5.5
: 3.5.5
Assigned To: Shmuel Melamud
sefi litmanovich
virt
: ZStream
: 1248379 (view as bug list)
Depends On: 1239153
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 04:02 EDT by rhev-integ
Modified: 2016-04-18 11:18 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-engine-3.5.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1239153
Environment:
Last Closed: 2015-10-26 14:33:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mgoldboi: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 43383 master MERGED core: Keep stateless snapshot on VM down for VMs from manual pool Never
oVirt gerrit 44326 ovirt-engine-3.5 MERGED core: Keep stateless snapshot on VM down for VMs from manual pool Never

  None (edit)
Comment 1 Michal Skrivanek 2015-07-30 05:35:53 EDT
*** Bug 1248379 has been marked as a duplicate of this bug. ***
Comment 2 sefi litmanovich 2015-10-13 05:47:37 EDT
Verified on rhevm-3.5.5-0.1.el6ev.noarch according to steps in comment:

1. Create a VM and add a disk to it.
2. Create a template based on the VM above.
3. Create a Manual Pool based on the template above.
4. Enter User Portal.
5. Take a VM from the Pool and run it.
6. Return back to Admin Portal.
7. Ensure the user have taken ownership on the VM and new snapshot was created.
8. Shutdown the VM.

Got the expected results:

After shutting down the vm, snapshot still exits and user permission still exists.
After removing the user permission, snapashot is deleted.
Comment 4 errata-xmlrpc 2015-10-26 14:33:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1938.html

Note You need to log in before you can comment on or make changes to this bug.