Bug 1248464 - wrong advice when new-app is used
wrong advice when new-app is used
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Fabiano Franz
Yan Du
:
: 1252647 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 07:08 EDT by Aleksandar Kostadinov
Modified: 2015-09-08 16:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 16:13:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksandar Kostadinov 2015-07-30 07:08:37 EDT
Description of problem:
> $ oc new-app --docker-image='openshift/mysql-55-centos7' --code='https://github.com/openshift/ruby-hello-world' -l 'app=hi' --env='MYSQL_USER=root,MYSQL_PASSWORD=test,MYSQL_DATABASE=test'
> ...
> A build was created - you can run `oc start-build ruby-hello-world` to start it.
> ...

The build starts automatically and user does not have to run the suggested command. If user runs the suggested command, a second build is started. I think this advice needs to be removed.

Version-Release number of selected component (if applicable):
1.0.2
Comment 1 Fabiano Franz 2015-08-16 17:10:36 EDT
*** Bug 1252647 has been marked as a duplicate of this bug. ***
Comment 2 Fabiano Franz 2015-08-17 15:23:23 EDT
Fixed in https://github.com/openshift/origin/pull/4218
Comment 3 openshift-github-bot 2015-08-17 20:48:04 EDT
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/3319f9f74b4ca46d65fcdd0ea30c7aa4b7dac12d
Bug 1248464 - fixes message about builds created by new-app
Comment 4 Aleksandar Kostadinov 2015-08-18 02:22:19 EDT
may we have a test build?
Comment 5 Yan Du 2015-08-18 02:57:09 EDT
Test on latest origin env, got message (Build "ruby-hello-world" created and started - you can run `oc status` to check the progress.) when create the app.

oc v1.0.4-330-gcca4a42
kubernetes v1.1.0-alpha.0-1605-g44c91b1


# oc new-app --docker-image='openshift/mysql-55-centos7' --code='https://github.com/openshift/ruby-hello-world' -l 'app=hi' --env='MYSQL_USER=root,MYSQL_PASSWORD=test,MYSQL_DATABASE=test'
imagestreams/mysql-55-centos7
deploymentconfigs/mysql-55-centos7
imagestreams/ruby-20-centos7
imagestreams/ruby-hello-world
buildconfigs/ruby-hello-world
deploymentconfigs/ruby-hello-world
services/mysql-55-centos7
services/ruby-hello-world
Build "ruby-hello-world" created and started - you can run `oc status` to check the progress.
Service "mysql-55-centos7" created at 172.30.70.83 with port mappings 3306.
Service "ruby-hello-world" created at 172.30.39.72 with port mappings 8080.
Run 'oc status' to view your app.

Issue have been fixed, Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.