Bug 1252647 - new-app output for S2I incorrectly suggests you can run a build with start-build
new-app output for S2I incorrectly suggests you can run a build with start-build
Status: CLOSED DUPLICATE of bug 1248464
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabiano Franz
Yanping Zhang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 20:53 EDT by Erik M Jacobs
Modified: 2015-08-16 17:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-16 17:10:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik M Jacobs 2015-08-11 20:53:03 EDT
oc new-app jboss-eap6-openshift~https://github.com/thoraxe/openshift3mlbparks.git
imagestreams/openshift3mlbparks
buildconfigs/openshift3mlbparks
deploymentconfigs/openshift3mlbparks
services/openshift3mlbparks
A build was created - you can run `oc start-build openshift3mlbparks` to start it.
Service "openshift3mlbparks" created at 172.30.169.206 with port mappings 8080->8080, 8443->8443.
Run 'oc status' to view your app.

oc version
oc v3.0.1.0-503-g7cc6deb
kubernetes v1.0.0


If I remember right, if I was to "start-build" after seeing this, I might possibly end up with *two* builds running because of the way OpenShift decides whether or not to run the first build.

We may want to remove that output from the client to prevent double-build issues.
Comment 2 Fabiano Franz 2015-08-16 17:10:36 EDT

*** This bug has been marked as a duplicate of bug 1248464 ***

Note You need to log in before you can comment on or make changes to this bug.