Bug 1248521 - quota : display the size equivalent to the soft limit percentage in gluster v quota <volname> list* command
quota : display the size equivalent to the soft limit percentage in gluster v...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Manikandan
: Reopened
Depends On:
Blocks: 1255644 1271184
  Show dependency treegraph
 
Reported: 2015-07-30 08:54 EDT by Manikandan
Modified: 2016-09-20 00:29 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1255644 1271184 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:28:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2015-07-30 08:54:01 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Manikandan 2015-07-30 08:59:15 EDT
Use case 1:

Currently, the "gluster v quota <volname> list <path>" outputs

For eg..,

[root@dhcp35-94 test]# gluster v quota vol1 list
                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/dir                                       5.0MB     80%          0Bytes   5.0MB              No                   No

Use case 2:

Also for "gluster v quota <volname> list-objects <path>" outputs,

For eg..,

[root@dhcp35-94 test]# gluster v quota vol1 list-objects /dir
                  Path                   Hard-limit   Soft-limit      Files       Dirs     Available  Soft-limit exceeded? Hard-limit exceeded?
-----------------------------------------------------------------------------------------------------------------------------------------------
/dir                                            10       80%          0          1          9              No                   No


It would be better if we could display the 80% soft limit equivalent value of the hard limit.
Comment 2 Anand Avati 2015-07-30 09:06:45 EDT
REVIEW: http://review.gluster.org/11808 (quota : display the size of soft limit percentage) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 3 Manikandan 2015-07-30 09:17:12 EDT
With the above patch, 

"gluster v quota <volname> list <path>" command outputs,

[root@dhcp35-94 test]# gluster v quota vol1 list
                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/dir                                       1.0GB     60%(614.4MB)   0Bytes   1.0GB              No                   No

"gluster v quota <volname> list-objects <path>" command shows,

[root@dhcp35-94 test]# gluster v quota vol1 list-objects /dir
                  Path                   Hard-limit   Soft-limit      Files       Dirs     Available  Soft-limit exceeded? Hard-limit exceeded?
-----------------------------------------------------------------------------------------------------------------------------------------------
/dir                                            10       80%(8)          0          1          9              No                   No
Comment 4 Anand Avati 2015-07-31 02:05:38 EDT
REVIEW: http://review.gluster.org/11808 (quota : display the size of soft limit percentage) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 5 Anand Avati 2015-08-02 23:29:14 EDT
REVIEW: http://review.gluster.org/11808 (quota : display the size of soft limit percentage) posted (#3) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 6 Anand Avati 2015-08-04 09:06:01 EDT
REVIEW: http://review.gluster.org/11808 (quota : display the size of soft limit percentage) posted (#4) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 7 Anand Avati 2015-08-12 03:29:03 EDT
REVIEW: http://review.gluster.org/11808 (quota : display the size of soft limit percentage) posted (#5) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 8 Anand Avati 2015-08-12 06:27:58 EDT
REVIEW: http://review.gluster.org/11808 (quota :display the size of soft limit percentage) posted (#6) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 9 Anand Avati 2015-08-13 01:12:47 EDT
REVIEW: http://review.gluster.org/11808 (quota :display the size of soft limit percentage) posted (#7) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 10 Anand Avati 2015-08-17 07:08:22 EDT
REVIEW: http://review.gluster.org/11808 (quota :display the size of soft limit percentage) posted (#8) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 11 Anand Avati 2015-08-20 07:11:23 EDT
REVIEW: http://review.gluster.org/11808 (quota :display the size of soft limit percentage) posted (#9) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 12 Vijay Bellur 2015-10-12 05:38:08 EDT
REVIEW: http://review.gluster.org/12337 (cli : freeing the allocated memory) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 13 Vijay Bellur 2015-10-12 08:27:48 EDT
REVIEW: http://review.gluster.org/12337 (cli : freeing the allocated memory) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 14 Vijay Bellur 2015-10-14 03:00:02 EDT
COMMIT: http://review.gluster.org/12337 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit a2976a2eb8c79cbec1009bec4c420b4874da25bc
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Mon Oct 12 15:03:28 2015 +0530

    cli : freeing the allocated memory
    
    Change-Id: Ibcbad94c091a9c24fe5aff2d7e8bcd9ac88da7bf
    BUG: 1248521
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/12337
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 15 Nagaprasad Sathyanarayana 2015-10-25 11:11:22 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 16 Niels de Vos 2016-06-16 09:28:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.