Bug 1271184 - quota : display the size equivalent to the soft limit percentage in gluster v quota <volname> list* command
Summary: quota : display the size equivalent to the soft limit percentage in gluster v...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: RHGS 3.1.2
Assignee: Manikandan
QA Contact: Anil Shah
URL:
Whiteboard:
Depends On: 1248521
Blocks: 1255644 1260783
TreeView+ depends on / blocked
 
Reported: 2015-10-13 10:53 UTC by Manikandan
Modified: 2016-09-20 04:29 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.7.5-5
Doc Type: Bug Fix
Doc Text:
Previously, only the soft limit was shown in percentage with 'gluster v quota <volname> list' command. With this fix, the remaining usable value in size is also displayed.
Clone Of: 1248521
Environment:
Last Closed: 2016-03-01 05:38:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0193 0 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 update 2 2016-03-01 10:20:36 UTC

Description Manikandan 2015-10-13 10:53:00 UTC
+++ This bug was initially created as a clone of Bug #1248521 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Manikandan on 2015-07-30 08:59:15 EDT ---

Use case 1:

Currently, the "gluster v quota <volname> list <path>" outputs

For eg..,

[root@dhcp35-94 test]# gluster v quota vol1 list
                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/dir                                       5.0MB     80%          0Bytes   5.0MB              No                   No

Use case 2:

Also for "gluster v quota <volname> list-objects <path>" outputs,

For eg..,

[root@dhcp35-94 test]# gluster v quota vol1 list-objects /dir
                  Path                   Hard-limit   Soft-limit      Files       Dirs     Available  Soft-limit exceeded? Hard-limit exceeded?
-----------------------------------------------------------------------------------------------------------------------------------------------
/dir                                            10       80%          0          1          9              No                   No


It would be better if we could display the 80% soft limit equivalent value of the hard limit.

--- Additional comment from Anand Avati on 2015-07-30 09:06:45 EDT ---

REVIEW: http://review.gluster.org/11808 (quota : display the size of soft limit percentage) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Manikandan on 2015-07-30 09:17:12 EDT ---

With the above patch, 

"gluster v quota <volname> list <path>" command outputs,

[root@dhcp35-94 test]# gluster v quota vol1 list
                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/dir                                       1.0GB     60%(614.4MB)   0Bytes   1.0GB              No                   No

"gluster v quota <volname> list-objects <path>" command shows,

[root@dhcp35-94 test]# gluster v quota vol1 list-objects /dir
                  Path                   Hard-limit   Soft-limit      Files       Dirs     Available  Soft-limit exceeded? Hard-limit exceeded?
-----------------------------------------------------------------------------------------------------------------------------------------------
/dir                                            10       80%(8)          0          1          9              No                   No

--- Additional comment from Anand Avati on 2015-07-31 02:05:38 EDT ---

REVIEW: http://review.gluster.org/11808 (quota : display the size of soft limit percentage) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-02 23:29:14 EDT ---

REVIEW: http://review.gluster.org/11808 (quota : display the size of soft limit percentage) posted (#3) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-04 09:06:01 EDT ---

REVIEW: http://review.gluster.org/11808 (quota : display the size of soft limit percentage) posted (#4) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-12 03:29:03 EDT ---

REVIEW: http://review.gluster.org/11808 (quota : display the size of soft limit percentage) posted (#5) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-12 06:27:58 EDT ---

REVIEW: http://review.gluster.org/11808 (quota :display the size of soft limit percentage) posted (#6) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-13 01:12:47 EDT ---

REVIEW: http://review.gluster.org/11808 (quota :display the size of soft limit percentage) posted (#7) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-17 07:08:22 EDT ---

REVIEW: http://review.gluster.org/11808 (quota :display the size of soft limit percentage) posted (#8) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-20 07:11:23 EDT ---

REVIEW: http://review.gluster.org/11808 (quota :display the size of soft limit percentage) posted (#9) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-12 05:38:08 EDT ---

REVIEW: http://review.gluster.org/12337 (cli : freeing the allocated memory) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-12 08:27:48 EDT ---

REVIEW: http://review.gluster.org/12337 (cli : freeing the allocated memory) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 6 Nag Pavan Chilakam 2015-10-15 09:17:08 UTC
gave ack, as the merge failed without ack and tiering code merge was getting affected without this merge

Comment 13 Anil Shah 2015-11-12 12:11:24 UTC
[root@localhost ~]# gluster v quota testvol list
                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/                                         10.0GB     80%(8.0GB)   0Bytes  10.0GB              No                   No
/test                                    100.0GB     80%(80.0GB)   0Bytes 100.0GB              No                   No

Modifying soft-limit percentage 
====================================================
[root@localhost ~]# gluster v quota testvol default-soft-limit 70
volume quota : success


[root@localhost ~]# gluster v quota testvol list
                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/                                         10.0GB      70(7.0GB)   0Bytes  10.0GB              No                   No
/test                                    100.0GB      70(70.0GB)   0Bytes 100.0GB              No                   No
[root@localhost ~]# gluster v quota testvol limit-usage /test1 100MB
volume quota : success
[root@localhost ~]# gluster v quota testvol list
                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/                                         10.0GB      70(7.0GB)   0Bytes  10.0GB              No                   No
/test                                    100.0GB      70(70.0GB)   0Bytes 100.0GB              No                   No
/test1                                   100.0MB      70(70.0MB)   0Bytes 100.0MB              No                   No


Bug verified on build glusterfs-3.7.5-6.el7rhgs.

Comment 15 errata-xmlrpc 2016-03-01 05:38:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html


Note You need to log in before you can comment on or make changes to this bug.