Bug 124861 - Using kickstart installation, firewall configuration fails
Using kickstart installation, firewall configuration fails
Status: CLOSED DUPLICATE of bug 123867
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-05-31 11:09 EDT by Pavel Urban
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Pavel Urban 2004-05-31 11:09:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b)

Description of problem:
When I try

firewall --enabled --port=ssh:tcp --port=dns:tcp --port=dns:udp

in ks-file during http://... kickstart installation, no firewall
configuration is in fact created. When I look at anaconda-ks.cfg on
installed system, I can see

firewall --enabled --port=ssh:tcp --port=dns:tcp --port=dns:udp
--port=ssh:tcp --port=dns:tcp --port=dns:udp

(all port arguments created twice).

My command line arguments:

linux text ksdevice=eth0 ks=

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. create network ks.cfg
2. add firewall --enabled --port=ssh:tcp --port=dns:tcp --port=dns:udp
to it
3. try network kickstart installation

Actual Results:  iptables -L -n shows no firewall rules applied, no
/etc/sysconfig/iptables file is created

Expected Results:  /etc/sysconfig/iptables file created with proper

Additional info:
Comment 1 Jeremy Katz 2004-06-01 16:30:37 EDT
Fixed in CVS for U3

*** This bug has been marked as a duplicate of 123867 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.