Bug 1248669 - all: Make all the xlator fops static to avoid incorrect symbol resolution
all: Make all the xlator fops static to avoid incorrect symbol resolution
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: unclassified (Show other bugs)
mainline
All All
unspecified Severity medium
: ---
: ---
Assigned To: Soumya Koduri
: Reopened, Triaged
: 1248470 (view as bug list)
Depends On:
Blocks: 1216951 1256485 1256606
  Show dependency treegraph
 
Reported: 2015-07-30 10:39 EDT by Soumya Koduri
Modified: 2016-06-16 09:28 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1256606 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:28:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Soumya Koduri 2015-07-30 10:39:20 EDT
Description of problem:

As described in the bug1245636, we have encountered an issue where in the 'snapview-client' xlator lookup fop name 'svc_lookup' matches with one of the routines provided by libntirpc, used by NFS-Ganesha. Hence while using 'uss' feature over NFS-Ganesha, during dlopen() of the snapview-client xlator, as  'svc_lookup' is already loaded, 'xlator->fops->lookup' incorrectly refers to that symbol.

To avoid similar issues, it would be better and cleaner to mark all the xlator fops static. This bug is to track all the required changes.
Comment 1 Soumya Koduri 2015-07-31 03:07:59 EDT
*** Bug 1248470 has been marked as a duplicate of this bug. ***
Comment 2 Anand Avati 2015-07-31 05:02:54 EDT
REVIEW: http://review.gluster.org/11805 (snapshot: Make fops static for correct resolution of symbols) posted (#3) for review on master by soumya k (skoduri@redhat.com)
Comment 3 Anand Avati 2015-08-04 08:54:22 EDT
REVIEW: http://review.gluster.org/11814 (build: export minimum symbols from xlators for correct resolution) posted (#21) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 4 Anand Avati 2015-08-24 13:23:13 EDT
COMMIT: http://review.gluster.org/11805 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit d5e03b7f02f68b3a9aaccf586e1f6ed901224ba7
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Thu Jul 30 16:37:45 2015 +0530

    snapshot: Make fops static for correct resolution of symbols
    
    Few of the snapshot fops (like 'svc_lookup') may not get resolved
    while using dynamic loading as there could be other libraries(like libntirpc)
    with same routine names. Making them static to resolve the same.
    
    Change-Id: I6577bf3705864f5583425c94427b4e1025a59bcd
    BUG: 1248669
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/11805
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 5 Vijay Bellur 2015-09-14 09:25:24 EDT
REVIEW: http://review.gluster.org/11814 (build: export minimum symbols from xlators for correct resolution) posted (#22) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 6 Vijay Bellur 2015-09-16 16:07:44 EDT
REVIEW: http://review.gluster.org/11814 (build: export minimum symbols from xlators for correct resolution) posted (#23) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 7 Vijay Bellur 2015-12-18 07:56:36 EST
REVIEW: http://review.gluster.org/13003 (build: export minimum symbols from xlators for correct resolution) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 8 Vijay Bellur 2015-12-18 08:14:30 EST
REVIEW: http://review.gluster.org/13003 (build: export minimum symbols from xlators for correct resolution) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 9 Vijay Bellur 2015-12-18 10:35:50 EST
REVIEW: http://review.gluster.org/13003 (build: export minimum symbols from xlators for correct resolution) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 10 Vijay Bellur 2015-12-22 12:15:04 EST
COMMIT: http://review.gluster.org/13003 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit e62c0fe19b113d42db5e0f80fa7cbb82f2f88190
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Fri Dec 18 07:44:45 2015 -0500

    build: export minimum symbols from xlators for correct resolution
    
    Revisiting http://review.gluster.org/#/c/11814/, which unintentionally
    introduced warnings from libtool about the xlator .so names.
    
    According to [1], the -module option must appear in the Makefile.am
    file(s); if -module is defined in a macro, e.g. in configure(.ac),
    then libtool will not recognize that this is a module and will emit a
    warning.
    
    [1]
    http://www.gnu.org/software/automake/manual/automake.html#Libtool-Modules
    
    Change-Id: Ifa5f9327d18d139597791c305aa10cc4410fb078
    BUG: 1248669
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13003
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: soumya k <skoduri@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 11 Niels de Vos 2016-06-16 09:28:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.