Bug 1249106 - Requirement for Database Size Management
Requirement for Database Size Management
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
unspecified
Unspecified Unspecified
high Severity medium
: z3
: 7.0 (Kilo)
Assigned To: Martin Magr
Leonid Natapov
: FutureFeature, Triaged, ZStream
Depends On: 1265249
Blocks: 1249179 1283388
  Show dependency treegraph
 
Reported: 2015-07-31 09:44 EDT by Alvaro Lopez Ortega
Modified: 2016-04-26 15:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-2015.1.8-24.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1283388 (view as bug list)
Environment:
Last Closed: 2015-12-21 12:09:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1183523 None None None Never
OpenStack gerrit 207909 None None None Never
OpenStack gerrit 207915 None None None Never
OpenStack gerrit 208939 None None None Never
OpenStack gerrit 209019 None None None Never
OpenStack gerrit 209053 None None None Never
OpenStack gerrit 209099 None None None Never
OpenStack gerrit 209129 None None None Never
OpenStack gerrit 209533 None None None Never
OpenStack gerrit 216782 None None None Never

  None (edit)
Description Alvaro Lopez Ortega 2015-07-31 09:44:12 EDT
Description of problem:

The DB associated with an OpenStack deployment (mariadb) acts as a system backend, storing configuration and historical data for certain OpenStack services, including Compute, Identity Service, and Block Storage.

It's important to put practices in place for maintaining the size of the database with regards to automatic purging of unneeded data.

Identity Service (Keystone) does it with a crontab entry like this:
0 */1 * * * /usr/bin/keystone-manage token_flush >/dev/null 2>&1

We ought to do something similar with the rest of the components:
0 */12 * * * /usr/bin/nova-manage db archive_deleted_rows >/dev/null 2>&1
0 */24 * * * /usr/bin/cinder-manage db purge 1 >/dev/null 2>&1

The related upstream bugs, reviews and blueprints follow:
https://bugs.launchpad.net/nova/+bug/1183523
https://review.openstack.org/#/c/200224/8
https://review.openstack.org/#/c/184645/
https://blueprints.launchpad.net/glance/+spec/database-purge
Comment 4 Martin Magr 2015-08-25 12:24:53 EDT
I went ahead and implemented db purge command for Glance myself. Hopefully this will pass upstream review quickly.
Comment 13 Ofer Blaut 2015-12-20 05:23:31 EST
checked openstack-puppet-modules-2015.1.8-32.el7ost.noarch

OSPD 7.2
Comment 15 errata-xmlrpc 2015-12-21 12:09:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2677

Note You need to log in before you can comment on or make changes to this bug.