Bug 1249191 - trace-cmd record crashes if -f is used before -e
trace-cmd record crashes if -f is used before -e
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: trace-cmd (Show other bugs)
7.2
All Linux
unspecified Severity medium
: rc
: 7.3
Assigned To: John Kacur
Ziqian SUN (Zamir)
: Reopened
Depends On:
Blocks: 1313485 1249194 1274397 RT7.3-RHELpkgs
  Show dependency treegraph
 
Reported: 2015-07-31 14:57 EDT by Daniel Bristot de Oliveira
Modified: 2017-06-14 01:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1249194 (view as bug list)
Environment:
Last Closed: 2016-11-04 04:07:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Bristot de Oliveira 2015-07-31 14:57:57 EDT
Description of problem:
The trace-cmd record command is crashing if a -f filter is used before
a -e event.

The usage a -f before a -e is a command line error, and trace-cmd
record detects this error by checking if the last_event pointer is NULL.

However, the last_event is not initialized as NULL and this command line
error is not detected. Then, the last_event is used to save the filter
options and this causes a segmentation fault because last_event was not
initialized yet.

Version-Release number of selected component (if applicable):
trace-cmd-2.2.1-6.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. # trace-cmd record -f foo

Actual results:
  # trace-cmd record -f foo
  Segmentation fault

Expected results:
  # trace-cmd record -f foo
  filter must come after event

Additional info:
  upstream patch proposed: https://lkml.org/lkml/2015/7/20/482
Comment 3 John Kacur 2015-11-17 19:01:53 EST
Tested-by: John Kacur <jkacur@redhat.com> sent upstream, will apply here.
Comment 11 errata-xmlrpc 2016-11-04 04:07:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2531.html

Note You need to log in before you can comment on or make changes to this bug.