Bug 1249194 - trace-cmd record crashes if -f is used before -e
trace-cmd record crashes if -f is used before -e
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: trace-cmd (Show other bugs)
6.8
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: John Kacur
Chunyu Hu
:
Depends On: 1249191
Blocks: 1217622 1269638 1270066
  Show dependency treegraph
 
Reported: 2015-07-31 15:09 EDT by Daniel Bristot de Oliveira
Modified: 2016-05-10 16:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1249191
Environment:
Last Closed: 2016-05-10 16:51:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Bristot de Oliveira 2015-07-31 15:09:58 EDT
+++ This bug was initially created as a clone of Bug #1249191 +++

Description of problem:
The trace-cmd record command is crashing if a -f filter is used before
a -e event.

The usage a -f before a -e is a command line error, and trace-cmd
record detects this error by checking if the last_event pointer is NULL.

However, the last_event is not initialized as NULL and this command line
error is not detected. Then, the last_event is used to save the filter
options and this causes a segmentation fault because last_event was not
initialized yet.

Version-Release number of selected component (if applicable):
trace-cmd-1.0.5-11.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. # trace-cmd record -f foo

Actual results:
  # trace-cmd record -f foo
  Segmentation fault

Expected results:
  # trace-cmd record -f foo
  filter must come after event

Additional info:
  upstream patch proposed: https://lkml.org/lkml/2015/7/20/482
Comment 2 John Kacur 2015-11-17 19:00:40 EST
Tested-by: John Kacur <jkacur@redhat.com> send upstream, will apply to our local build
Comment 3 John Kacur 2015-11-18 08:49:40 EST
Fixed in version 2.2.4-2 and up
Comment 8 errata-xmlrpc 2016-05-10 16:51:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0802.html

Note You need to log in before you can comment on or make changes to this bug.