Bug 124926 - airo driver does not enable MiniPCI airo cards on 2.6.6-1.403
airo driver does not enable MiniPCI airo cards on 2.6.6-1.403
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-01 10:49 EDT by Dan Williams
Modified: 2013-07-02 22:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:10:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2004-06-01 10:49:53 EDT
IBM Thinkpad T41 with builtin Airo MiniPCI.  AIRONET Wireless
Communications Cisco Aironet Wireless 802.11b, using firmware 5.00.03
which was known to work eith 2.6.6-1.381

Works on 2.6.6-1.381.  /var/log/messages contains:

airo: Probing for PCI adapters
airo: MAC enabled eth0 0:2:8a:ef:2a:31
airo: Finished probing for PCI adapters
e1000: Ignoring new-style parameters in presence of obsolete ones
Intel(R) PRO/1000 Network Driver - version 5.2.52-k2
Copyright (c) 1999-2004 Intel Corporation
e1000: eth1: e1000_probe: Intel(R) PRO/1000 Network Connection
airo: Unregistering eth0
ip_tables: (C) 2000-2002 Netfilter core team
airo: Probing for PCI adapters
airo: cmd= 121
airo: status= 7f21
airo: Rsp0= 6
airo: Rsp1= 0
airo: Rsp2= 2eab
airo: MAC could not be enabled
airo: Finished probing for PCI adapters
e1000: Ignoring new-style parameters in presence of obsolete ones
....

All entries above are timestamped Jun 1 09:31:25

When the system is up, an lsmod shows that airo is loaded, but nothing
depends on airo.  Airo is in /etc/sysconfig/hwconf where the adapter
is listed as using eth0.  It is also in /etc/modprobe.conf where it is
aliased to eth0.  However, when up, no iwconfig or ifconfig shows
anything about eth0, it seems to not even exist.
Comment 1 Dan Williams 2004-06-01 10:55:39 EDT
Bug seems similar to bug 124425
Comment 2 Dejan Kolar 2004-06-01 11:56:33 EDT
Same thing hapens to me with Airo340 PCI card which works fine on
RH9.0 but I did not succeed to  make it work on Fedora Core 2.

Anyone succeded?

Please where to find fimware 5.00.03 for Airo340 PCI card, on cisco
site there are only 4.25.30 and the next is 5.02.XX which is declared
as not working with Fedora.
Is it a Fedora problem or general problem with kernel 2.6.X?
Comment 3 Dan Williams 2004-06-01 12:36:50 EDT
The 5.00.03 firmware is available for Windows, grab the .exe
self-extracting copy of that firmware from Cisco (select Win95/98 I
believe) and then "unzip" that from the linux command line.  You'll
get a file that is the firmware.  BEWARE though that you cannot
successfully flash the card's firmware from linux unless the firmware
is already a certain version.  I was able to flash from 5.20.37 down
to 5.00.03, but other versions of the firmware a KNOWN to make the
card a brick.  (the reason is that the firmware flashing procedure
under Linux involves echoing data to an entry in /proc and unless the
driver/firmware is already somewhat working you're hosed.)  I can't be
responsible for any damage that you do to your card.

In short, the best way to flash the firmware down is to use Windows :(
Comment 4 David Carrigan 2004-06-13 18:23:16 EDT
New Worries:

I too have had some issues with this card, but downloading Cisco's
latest Linux and MS material:

http://www.cisco.com/pcgi-bin/tablebuild.pl/aironet_firmware_350

and flashing the card (also MPI350 in a ThinkPad T41) under MS's OS
to 5.30.17 yielded a *working* wireless NIC with Fedora Core 2,
kernel-2.6.6.1-422.

I removed the "HWADDR" param, and replaced "Ethernet" with "Wireless"
in /etc/sysconfig/network-scripts/ifcfg-eth1, also adding
/etc/sysconfig/network-scripts/keys-eth1 with "KEY=" only and it
just worked... with and without WEP(setting this with Cisco's ACU).

While not supported, the RHL9 compiled binary `acu' shipped by
Cisco works under FC2 too.

However, the latest Fedora Core 2 kernel, 2.6.6-1.427 *breaks*
it all again! I say breaks because it reverts to code for the
older 5.00.X firmware which did not support WEP under Linux
drivers up to 2.6.5-1.358.

Looking at both airo.c files from 422 to 427 it seems that the
decision was made to support only the early firmware revs in
427... see lines from:

3667 in ario.c of kernel-2.6.6-1.422
3557 in airo.c of kernel-2.6.6-1.427

And that's just the half of it.

Firmware 5.30.17 works for Fedora Core 2 kernel-2.6.6-1.422, so
why was airo.c re-worked for the older fw?!

Here are the configs which worked(sic) under 422:

/etc/modprobe.conf
alias eth1 airo
## no WEP
options airo auto_wep=0 probe=0
## with WEP
# options airo auto_wep=<key index> probe=0
install airo /sbin/modprobe --ignore-install airo && \
    /sbin/ip link set eth1 up dynamic on address <my MPI350 MAC> \
    >/dev/null 2>&1 || :

With these lines, and the following ifcfg-eth1, and keys-eth1, I
am able to access and use this wireless NIC.

/etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
TYPE=Wireless
ONBOOT=no
USERCTL=yes
BOOTPROTO=dhcp

/etc/sysconfig/network-scripts/keys-eth1
KEY=

Why the regression?
Comment 5 Dan Williams 2004-06-14 09:05:06 EDT
Part of the problem is that most of the people with T41s here in
Westford are actually running Linux, not Windows.  Therefore, to be
able to _reliably_ flash the firmware, we either have to replace the
hard drive with one that's got windows on it and swap the old one in
after the flash is done, or blow away our drives to be able to upgrade
the firmware.  In an ideal world the driver would be able to support
both versions of firmware, I'm not sure how hard that would be though.

WEP seems to work just fine with 5.00.03 and 2.6.6 kernels (of course
not -1.400 to -1.422) here...
Comment 6 Dan Williams 2004-08-15 11:57:53 EDT
I'm using 128/104bit WEP just fine with Fedora Core kernel 2.6.7-1.517
and a PCMCIA Aironet 350 card on my laptop (obviously not the MiniPCI
internal card on the thinkpads, I'm on a dell).  Anyway, I had just
upgraded the firmware on the card to latest Cisco firmware, which is
5.41.x, and it seems to work just great with the above Rawhide kernel.

Since the reason why we were _down_flashing the cards to 5.00.03 was
that they didn't work with the newer firmware and current kernels, it
seems that we can use newer firmware just fine now.  Since I was just
using the card with 5.00.03 as well, the current kernel seems to work
great with both versions of the firmware for PCMCIA cards at least.
Comment 7 Dave Jones 2004-11-27 15:21:37 EST
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?
Comment 8 Dan Williams 2005-04-05 09:57:49 EDT
More info: in-kernel airo drivers will not work with WEP and firmware versions >
5.20.x.  5.30.17 definitely does _not_ work with WEP, and there are significant
differences between the Cisco-provided drivers for 2.4 that _do_ work with
5.30.17 and the in-kernel drivers that do not.
Comment 9 Dave Jones 2005-04-16 01:10:19 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.