Bug 12493 - rpm -qf 'nit' on directories
Summary: rpm -qf 'nit' on directories
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 9668 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-19 00:46 UTC by R P Herrold
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-19 00:46:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description R P Herrold 2000-06-19 00:46:44 UTC
rpm -qf on a directory with the trailing / returns an error.

This is wrong behavior but not crippling:

[root@localhost mail]# rpm -qf /var/spool/mail/
*** db3 dbcursor->c_get rc -1 Invalid argument
error getting "" records from Basenames index
file /var/spool/mail/ is not owned by any package
[root@localhost mail]# rpm -qf /var/spool/mail 
filesystem-2.0.2-1
[root@localhost mail]# 

Solution -- if there is a training /  chop it off a 'filename' before
running the query.

Comment 1 Jeff Johnson 2000-07-10 18:22:34 UTC
Fixed in rpm-4.0-0.47. BTW, the following will now work as well

	cd /bin
	rpm -qf .

Thanks for the report.

Comment 2 Jeff Johnson 2000-07-21 13:56:21 UTC
*** Bug 9668 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.