Bug 9668 - rpm -qf does not recognize directories correctly
rpm -qf does not recognize directories correctly
Status: CLOSED DUPLICATE of bug 12493
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-22 09:29 EST by Moritz Barsnick
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-22 09:29:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2000-02-22 09:29:18 EST
In "rpm" upto at least 3.0.4-0.30, querying packages owning directories
fails if the directory is given with a postfixed "/" (e.g. when
<TAB>-expanding it in a shell):

barsnick@sunshine:~ # rpm -qf /usr/lib/sendmail-cf/
file /usr/lib/sendmail-cf/ is not owned by any package
barsnick@sunshine:~ # rpm -qf /usr/lib/sendmail-cf
sendmail-cf-8.9.3-16
barsnick@sunshine:~ # rpm --version
RPM version 3.0.4
barsnick@sunshine:~ # rpm -q rpm
rpm-3.0.4-0.30
Comment 1 Jeff Johnson 2000-07-21 09:56:24 EDT

*** This bug has been marked as a duplicate of 12493 ***

Note You need to log in before you can comment on or make changes to this bug.