Bug 1249367 - Since last update of shared-mime-info my google-chrome is no longer default. Set as default in pref apps
Since last update of shared-mime-info my google-chrome is no longer default. ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: shared-mime-info (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-01 22:30 EDT by Randall "Randy" Berry
Modified: 2015-08-02 13:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-02 13:28:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randall "Randy" Berry 2015-08-01 22:30:10 EDT
Description of problem:
Since the last update this evening chrome has been removed as my preferred application even though it has been set in Pref-Apps as so. All HTTP/HTTPS links are now loaded in Firefox. All mime-types of the like also point to chrome.

My last update began Sat Aug  1 18:09:58 (EDT) 2015 when webkit was updated. Prior to this update all urls were opened in chrome.
http://paste.fedoraproject.org/250633/38481034

Version-Release number of selected component (if applicable):
webkitgtk4-0:2.8.4-3.fc22.x86_64

How reproducible:
Every URL

Steps to Reproduce:
1. Run any application (terminal/irc/etc..)
2. Try to execute a http/https link
3. The link will be opened in Firefox regardless of preferred setting.

Actual results:
Firefox is opened, not the preferred application.

Expected results:
Open preferred application

Additional info:
Xfce4.12

If this is not the culprit please re-direct.
Comment 1 Randall "Randy" Berry 2015-08-01 22:32:43 EDT
The only application I can get URLs to open in chrome is chrome itself.
Comment 2 Randall "Randy" Berry 2015-08-01 23:51:19 EDT
Ah, I believe shared-mime-info is the culprit. Why is this package changing users preferences? I was left to dig to find out how to get my settings back.
Comment 3 Rex Dieter 2015-08-02 11:37:01 EDT
If you already have customized items, shared-mime-info shouldn't change (or override that).

Otherwise, if you had no prior preference, shared-mime-info will default to firefox now (due to fix for bug #1243049)
Comment 4 Michael Catanzaro 2015-08-02 13:28:54 EDT
Closing as NOTABUG, but I will note that this update should probably not have gone out in a stable release, but have been reserved for F23, since I agree we should not change default applications mid-release. I know from the discussion on the devel list that there was an extenuating circumstance in this case, so it's arguable, of course. Anyway it's too late now, moving on....

Note You need to log in before you can comment on or make changes to this bug.