Bug 124940 - Error message when starting cups
Summary: Error message when starting cups
Status: CLOSED DUPLICATE of bug 124217
Alias: None
Product: Fedora
Classification: Fedora
Component: cups   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-01 15:42 UTC by Daniel Malmgren
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Malmgren 2004-06-01 15:42:17 UTC
Description of problem:
I get the following when starting cups:
[~/empty#] service cups restart
Stoppar cups:                                     [     OK     ]
Startar cups: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import backend
  File "/usr/share/printconf/util/backend.py", line 54, in ?
    which = cups_import.which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment
                                                  [     OK     ]

Version-Release number of selected component (if applicable):
cups-1.1.20-12

How reproducible:
100%

Steps to Reproduce:
Start cups service

Additional info:
All relevant packages are latest rawhide versions. I didn't get the
same error in previous version (think it was 1.1.20-6).

Comment 1 Daniel Malmgren 2004-06-01 15:43:12 UTC
Oh. I also get the same message when trying to start
system-config-printer.

Comment 2 Tim Waugh 2004-06-01 16:08:34 UTC
Does it work if you start it like 'LANG=C system-config-printer'?

Comment 3 Daniel Malmgren 2004-06-01 16:17:24 UTC
Yes it does.

Comment 4 Tim Waugh 2004-06-01 16:28:15 UTC

*** This bug has been marked as a duplicate of 124217 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:03:54 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.