Bug 124217 - UnboundLocalError during start of cups
UnboundLocalError during start of cups
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
: 124940 127368 131380 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-24 15:36 EDT by Jochen Schmitt
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.6.100-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-01 12:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2004-05-24 15:36:36 EDT
I have installed cups-1.1.20-8.

when I boot linux, I got the following error messages

cups starten: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import backend
  File "/usr/share/printconf/util/backend.py", line 54, in ?
    which = cups_import.which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment

Best Regards:

Jochen Schmitt
Comment 1 Tim Waugh 2004-05-24 17:01:06 EDT
What does '/usr/sbin/alternatives --display print' say?
Comment 2 Jochen Schmitt 2004-05-25 11:27:00 EDT
The prooblem seems, that you have to set LANG='C' before
/usr/sbin/alternatives should be called.

Becouse, I am living in germany, LANG will be not set to 'C' at 
default, so I get the german output from /usr/sbin/alternatives

Best Regards:

Jochen Schmitt
Comment 3 Tim Waugh 2004-05-26 04:17:34 EDT
Thanks.  Fixed in CVS.
Comment 4 Tim Waugh 2004-06-01 12:28:17 EDT
*** Bug 124940 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Malmgren 2004-06-03 10:22:46 EDT
I don't get the bug when starting cups anymore. I still however get
almost the same error when starting system-config-printer (0.6.100-1):

Traceback (most recent call last):
  File "/usr/sbin/system-config-printer", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 1235, in ?
    queueTree()
  File "/usr/share/printconf/util/queueTree.py", line 268, in __init__
    self.active_spooler = self.get_active_spooler ()
  File "/usr/share/printconf/util/queueTree.py", line 290, in
get_active_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment

(damnit! Why isn't I allowed to reopen this bug?)
Comment 6 Tim Waugh 2004-06-03 11:21:39 EDT
Ah, there were other places that it gets invoked.  Fixed in 0.6.101-1.
Comment 7 Tim Waugh 2004-07-07 10:07:36 EDT
*** Bug 127368 has been marked as a duplicate of this bug. ***
Comment 8 Tim Waugh 2004-09-01 06:43:42 EDT
*** Bug 131380 has been marked as a duplicate of this bug. ***
Comment 10 Stéphane Chapeau 2004-11-19 10:58:56 EST
This bug appear if you modify your /etc/sysconfig/i18n to disable 
UTF8 for example, and you set a lot of variable starting with LC_. 
  
You can fix the problem by using only 4 variable these for French for 
example of /etc/sysconfig/i18n without UTF8 by def 
 
SYSFONTACM=iso15 
LANG=fr_FR 
SUPPORTED="en_US.UTF-8:en_US:en:fr_FR.UTF-8:fr_FR:fr" 
SYSFONT=lat0-16 

Note You need to log in before you can comment on or make changes to this bug.