Bug 1249439 - virt-what does not identify rhev/ovirt
virt-what does not identify rhev/ovirt
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-what (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks: 1301844 1359965 1364808
  Show dependency treegraph
 
Reported: 2015-08-02 21:49 EDT by Ryan Barry
Modified: 2017-03-21 07:28 EDT (History)
6 users (show)

See Also:
Fixed In Version: virt-what-1.11-1.3.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 07:28:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Barry 2015-08-02 21:49:01 EDT
Description of problem:
virt-what reports ovirt/rhev guests as "kvm" instead of 'ovirt' or 'rhev'

Version-Release number of selected component (if applicable):
virt-what-1.11-1.2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run virt-what in a rhev/ovirt guest
2.
3.

Actual results:
kvm

Expected results:
ovirt (or rhev, as 

Additional info:
This can be checked in dmidecode:
Manufacturer: oVirt
Product Name: oVirt Node

(it's also oVirt Node for the guests)
Comment 2 Richard W.M. Jones 2015-08-03 07:26:06 EDT
Untested patch posted here:
https://bugzilla.redhat.com/show_bug.cgi?id=1249438#c3
Comment 4 Richard W.M. Jones 2016-08-23 14:06:16 EDT
This is fixed upstream now.
Comment 6 Bin Han 2016-11-02 04:48:17 EDT
Packager version:
virt-what-1.11-1.3.el6.x86_64


Steps:
1.prepare a RHEL6.9 guest in rhev
2.Update the virt-what to the latest version
3.Run "Virt-what" 

[root@localhost ~]# virt-what 
rhev
kvm

So verified.
Comment 8 errata-xmlrpc 2017-03-21 07:28:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0748.html

Note You need to log in before you can comment on or make changes to this bug.