Bug 1249499 - Make ping-timeout option configurable at a volume-level
Summary: Make ping-timeout option configurable at a volume-level
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: krishnan parthasarathi
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 983307 1250810 1252359
TreeView+ depends on / blocked
 
Reported: 2015-08-03 08:06 UTC by krishnan parthasarathi
Modified: 2016-06-16 13:28 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1250810 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:28:07 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description krishnan parthasarathi 2015-08-03 08:06:01 UTC
Description of problem:
A gluster volume can have ping-timeout values different from the default 42 secs. This can be done by setting network.ping-timeout option on the volume.

e.g,
# gluster volume set <VOLNAME> network.ping-timeout <preferred-value>

Currently, volume-set doesn't update the ping-timeout on running mounts.


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. Mount a gluster volume with default ping-timeout value.
2. Change the ping-timeout to a different value with the volume-set command mentioned above.
3. Simulate a network disconnection using iptables(8) or attach gdb to one of the brick processes.

Actual results:
The ping-timeout isn't updated on running mount processes.

Expected results:
The ping-timeout should take effect on running mount processes.


Additional info:

Comment 1 Anand Avati 2015-08-03 08:06:46 UTC
REVIEW: http://review.gluster.org/11818 (client, rpc: make ping-timeout configurable for glusterfs clients) posted (#1) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)

Comment 2 Anand Avati 2015-08-05 07:25:02 UTC
COMMIT: http://review.gluster.org/11818 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 3403370ebeaf16567b79022c6ac48b2e0cd50db5
Author: Krishnan Parthasarathi <kparthas@redhat.com>
Date:   Mon Aug 3 13:28:09 2015 +0530

    client, rpc: make ping-timeout configurable for glusterfs clients
    
    Change-Id: Idd94adb0457aaffce7330f56f98cebafa2c4dae8
    BUG: 1249499
    Signed-off-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-on: http://review.gluster.org/11818
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 14:57:17 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 4 Niels de Vos 2016-06-16 13:28:07 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.