Bug 1250810 - Make ping-timeout option configurable at a volume-level
Make ping-timeout option configurable at a volume-level
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: rpc (Show other bugs)
3.7.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On: 1249499
Blocks: 983307 glusterfs-3.7.4 1252359
  Show dependency treegraph
 
Reported: 2015-08-06 00:38 EDT by krishnan parthasarathi
Modified: 2015-11-03 18:06 EST (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1249499
Environment:
Last Closed: 2015-09-09 05:39:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description krishnan parthasarathi 2015-08-06 00:38:00 EDT
+++ This bug was initially created as a clone of Bug #1249499 +++

Description of problem:
A gluster volume can have ping-timeout values different from the default 42 secs. This can be done by setting network.ping-timeout option on the volume.

e.g,
# gluster volume set <VOLNAME> network.ping-timeout <preferred-value>

Currently, volume-set doesn't update the ping-timeout on running mounts.


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. Mount a gluster volume with default ping-timeout value.
2. Change the ping-timeout to a different value with the volume-set command mentioned above.
3. Simulate a network disconnection using iptables(8) or attach gdb to one of the brick processes.

Actual results:
The ping-timeout isn't updated on running mount processes.

Expected results:
The ping-timeout should take effect on running mount processes.


Additional info:

--- Additional comment from Anand Avati on 2015-08-03 04:06:46 EDT ---

REVIEW: http://review.gluster.org/11818 (client, rpc: make ping-timeout configurable for glusterfs clients) posted (#1) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)

--- Additional comment from Anand Avati on 2015-08-05 03:25:02 EDT ---

COMMIT: http://review.gluster.org/11818 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 3403370ebeaf16567b79022c6ac48b2e0cd50db5
Author: Krishnan Parthasarathi <kparthas@redhat.com>
Date:   Mon Aug 3 13:28:09 2015 +0530

    client, rpc: make ping-timeout configurable for glusterfs clients
    
    Change-Id: Idd94adb0457aaffce7330f56f98cebafa2c4dae8
    BUG: 1249499
    Signed-off-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-on: http://review.gluster.org/11818
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 1 Kaushal 2015-09-09 05:39:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.