Bug 1249654 - New Host Network API is missing QOS support
New Host Network API is missing QOS support
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
urgent Severity unspecified (vote)
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Martin Mucha
Pavel Stehlik
network
:
: 1249657 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 09:51 EDT by Barak
Modified: 2016-02-10 14:16 EST (History)
8 users (show)

See Also:
Fixed In Version: 3.6.0-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 06:34:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: Triaged+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 43986 master MERGED restapi: rest part for HostNetworkQos Never
oVirt gerrit 45203 ovirt-engine-3.6 MERGED core: persisting NetworkattAchments HostNetworkQos data Never
oVirt gerrit 45204 ovirt-engine-3.6 MERGED core: extracted InterfacesSpeed calculation methods. Never
oVirt gerrit 45205 ovirt-engine-3.6 MERGED core: new procedure to get network attachment by networkId and nicId Never
oVirt gerrit 45206 ovirt-engine-3.6 MERGED core: new procedure to get nic by its name Never
oVirt gerrit 45208 ovirt-engine-3.6 MERGED webadmin: validating qos & using overridden qos in HostSetupNetworksCommand Never
oVirt gerrit 45209 ovirt-engine-3.6 MERGED webamin: Disable qos for out-of-sync network Never
oVirt gerrit 45210 ovirt-engine-3.6 MERGED engine: Remove Host Network QoS commitment validation Never
oVirt gerrit 45284 ovirt-engine-3.6 MERGED restapi: refactored out updateActionTypeForQosType method Never
oVirt gerrit 45285 ovirt-engine-3.6 MERGED restapi: refactored QoSMapper Never
oVirt gerrit 45286 ovirt-engine-3.6 MERGED restapi: rest part for HostNetworkQos Never
oVirt gerrit 45431 ovirt-engine-3.6 MERGED restapi: reporting HostNetworkQos also on HostNic and Network Never

  None (edit)
Description Barak 2015-08-03 09:51:51 EDT
Need to add support for QOS to the new host network api.
Comment 1 Yaniv Lavi 2015-10-18 09:35:34 EDT
*** Bug 1249657 has been marked as a duplicate of this bug. ***
Comment 2 Sandro Bonazzola 2015-11-04 06:34:11 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.