Bug 1249945 - Update SELinux policy for rh-nginx18 collection
Update SELinux policy for rh-nginx18 collection
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.1
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
: ZStream
Depends On:
Blocks: 1249949 1270839
  Show dependency treegraph
 
Reported: 2015-08-04 04:22 EDT by Martin Frodl
Modified: 2015-11-19 05:42 EST (History)
8 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-43.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1249949 1270839 (view as bug list)
Environment:
Last Closed: 2015-11-19 05:42:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Frodl 2015-08-04 04:22:37 EDT
Description of problem:

Please update SELinux policy to assign the following types to files provided by rh-nginx18 collection:

/etc/opt/rh/rh-nginx18/nginx(/.*)?          httpd_config_t
/var/opt/rh/rh-nginx18/lib/nginx(/.*)?      httpd_var_lib_t
/var/opt/rh/rh-nginx18/run/nginx(/.*)?      httpd_var_run_t
/var/opt/rh/rh-nginx18/log(/.*)?            httpd_log_t

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-23.el7.noarch
Comment 4 Lukas Vrabec 2015-08-12 07:50:48 EDT
Is this necessary for RHEL-7.2? Can we move it to 7.3?

Thank you!
Comment 5 Martin Frodl 2015-08-19 04:09:29 EDT
If we want to have SELinux policy properly set for rh-nginx18 when the collection is released, we need to have this fixed in RHEL 7.2, and probably RHEL 7.1.z too. I cannot imagine very well this could wait until RHEL 7.3.
Comment 8 Lukas Vrabec 2015-08-19 05:09:06 EDT
commit d5b059462c0dae69ad1e30215b52353f767c22fb
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Wed Aug 19 11:07:08 2015 +0200

    Added labels for files provided by rh-nginx18 collection
    Resolves: #1249945
Comment 13 errata-xmlrpc 2015-11-19 05:42:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2300.html

Note You need to log in before you can comment on or make changes to this bug.