Bug 1250038 - [abrt] python-dnf: completion_helper.py:84:run:IndexError: list index out of range
Summary: [abrt] python-dnf: completion_helper.py:84:run:IndexError: list index out of ...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 22
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:6b0371f5d0565c30f943805339e...
Keywords:
: 1257440 1268160 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-04 12:01 UTC by Lukee
Modified: 2017-01-16 14:10 UTC (History)
10 users (show)

Fixed In Version: dnf-1.1.2-4.fc23 dnf-1.1.2-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 19:13:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (847 bytes, text/plain)
2015-08-04 12:01 UTC, Lukee
no flags Details
File: environ (2.48 KB, text/plain)
2015-08-04 12:01 UTC, Lukee
no flags Details

Description Lukee 2015-08-04 12:01:45 UTC
Version-Release number of selected component:
python-dnf-1.0.1-2.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        python2 /usr/lib/python2.7/site-packages/dnf/cli/completion_helper.py list list --show -d 0 -q -C
executable:     /usr/lib/python2.7/site-packages/dnf/cli/completion_helper.py
kernel:         4.1.3-200.fc22.i686
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
completion_helper.py:84:run:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dnf/cli/completion_helper.py", line 189, in <module>
    main(sys.argv[1:])
  File "/usr/lib/python2.7/site-packages/dnf/cli/completion_helper.py", line 185, in main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1077, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/completion_helper.py", line 84, in run
    print("\n".join(filter_list_by_kw(args[1], subcmds)))
IndexError: list index out of range

Local variables in innermost frame:
self: <__main__.ListCompletionCommand object at 0xb595120c>
args: ['list']
subcmds: [u'all', u'available', u'installed', u'updates', u'extras', u'autoremove', u'obsoletes', u'recent']

Comment 1 Lukee 2015-08-04 12:01:48 UTC
Created attachment 1059054 [details]
File: backtrace

Comment 2 Lukee 2015-08-04 12:01:50 UTC
Created attachment 1059055 [details]
File: environ

Comment 3 Honza Silhan 2015-08-11 13:32:46 UTC
Igor, is it duplicate of bug 1220040?

Comment 4 Honza Silhan 2015-09-01 11:56:36 UTC
*** Bug 1257440 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2015-09-22 15:01:27 UTC
hawkey-0.6.1-1.fc23 dnf-plugins-core-0.1.12-2.fc23 dnf-1.1.2-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16428

Comment 6 Fedora Update System 2015-09-22 15:03:20 UTC
dnf-plugins-core-0.1.12-2.fc22 hawkey-0.6.1-1.fc22 dnf-1.1.2-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16429

Comment 7 Fedora Update System 2015-09-23 03:54:52 UTC
dnf-1.1.2-2.fc23, dnf-plugins-core-0.1.12-2.fc23, hawkey-0.6.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf-plugins-core dnf hawkey'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16428

Comment 8 Fedora Update System 2015-09-23 21:22:43 UTC
dnf-1.1.2-2.fc22, dnf-plugins-core-0.1.12-2.fc22, hawkey-0.6.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf-plugins-core dnf hawkey'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16429

Comment 9 Fedora Update System 2015-10-02 15:19:50 UTC
dnf-plugins-core-0.1.12-3.fc23 hawkey-0.6.1-2.fc23 dnf-1.1.2-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-38e69423f3

Comment 10 Fedora Update System 2015-10-02 15:24:11 UTC
dnf-plugins-core-0.1.12-3.fc22 hawkey-0.6.1-2.fc22 dnf-1.1.2-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-3528c659e4

Comment 11 Fedora Update System 2015-10-04 01:35:50 UTC
dnf-1.1.2-4.fc22, dnf-plugins-core-0.1.12-3.fc22, hawkey-0.6.1-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update hawkey dnf-plugins-core dnf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-3528c659e4

Comment 12 Fedora Update System 2015-10-04 01:51:45 UTC
dnf-1.1.2-4.fc23, dnf-plugins-core-0.1.12-3.fc23, hawkey-0.6.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update hawkey dnf-plugins-core dnf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-38e69423f3

Comment 13 Fedora Update System 2015-10-04 19:12:35 UTC
dnf-1.1.2-4.fc23, dnf-plugins-core-0.1.12-3.fc23, hawkey-0.6.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2015-10-05 21:52:06 UTC
dnf-1.1.2-4.fc22, dnf-plugins-core-0.1.12-3.fc22, hawkey-0.6.1-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Honza Silhan 2015-10-13 13:38:44 UTC
*** Bug 1268160 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.