Bug 1257440 - [abrt] python3-dnf: completion_helper.py:84:run:IndexError: list index out of range
[abrt] python3-dnf: completion_helper.py:84:run:IndexError: list index out of...
Status: CLOSED DUPLICATE of bug 1250038
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6b0371f5d0565c30f943805339e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 01:50 EDT by Kai A. Hiller
Modified: 2015-09-01 07:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 07:56:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (845 bytes, text/plain)
2015-08-27 01:50 EDT, Kai A. Hiller
no flags Details
File: environ (2.24 KB, text/plain)
2015-08-27 01:50 EDT, Kai A. Hiller
no flags Details

  None (edit)
Description Kai A. Hiller 2015-08-27 01:50:35 EDT
Version-Release number of selected component:
python3-dnf-1.1.0-2.fc24

Additional info:
reporter:       libreport-2.6.2
cmdline:        python3 /usr/lib/python3.4/site-packages/dnf/cli/completion_helper.py list kernel --showdu -d 0 -q -C
executable:     /usr/lib/python3.4/site-packages/dnf/cli/completion_helper.py
kernel:         4.2.0-0.rc8.git1.1.fc24.x86_64
runlevel:       5 3
type:           Python3
uid:            1000

Truncated backtrace:
completion_helper.py:84:run:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/dnf/cli/completion_helper.py", line 191, in <module>
    main(sys.argv[1:])
  File "/usr/lib/python3.4/site-packages/dnf/cli/completion_helper.py", line 187, in main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1083, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/completion_helper.py", line 84, in run
    print("\n".join(filter_list_by_kw(args[1], subcmds)))
IndexError: list index out of range

Local variables in innermost frame:
self: <__main__.ListCompletionCommand object at 0x7efd13750ba8>
args: ['kernel']
subcmds: ['all', 'available', 'installed', 'updates', 'extras', 'autoremove', 'obsoletes', 'recent']

Potential duplicate: bug 1250038
Comment 1 Kai A. Hiller 2015-08-27 01:50:41 EDT
Created attachment 1067509 [details]
File: backtrace
Comment 2 Kai A. Hiller 2015-08-27 01:50:43 EDT
Created attachment 1067510 [details]
File: environ
Comment 3 Honza Silhan 2015-09-01 07:56:36 EDT

*** This bug has been marked as a duplicate of bug 1250038 ***

Note You need to log in before you can comment on or make changes to this bug.