Bug 1250303 - Unexpected error messages are output in /var/log/ceilometer/central.log.
Unexpected error messages are output in /var/log/ceilometer/central.log.
Status: CLOSED DUPLICATE of bug 1283014
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
medium Severity medium
: ---
: 6.0 (Juno)
Assigned To: Mehdi ABAAKOUK
Yurii Prokulevych
: Triaged, ZStream
Depends On:
Blocks: 1386586
  Show dependency treegraph
 
Reported: 2015-08-05 01:16 EDT by Chen
Modified: 2016-12-08 02:52 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1386586 (view as bug list)
Environment:
Last Closed: 2016-11-28 08:15:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chen 2015-08-05 01:16:33 EDT
Description of problem:

The following error messages is output after creating an instance.

/var/log/ceilometer/central.log

2015-08-04 19:21:52.902 32542 ERROR ceilometer.hardware.discovery [-] Couldn't obtain IP address ofinstance <the id of the instance>

Version-Release number of selected component (if applicable):

OSP 5.0 on RHEL7

openstack-ceilometer-compute-2014.2.3-5.el7ost.noarch
openstack-ceilometer-collector-2014.2.3-5.el7ost.noarch
openstack-ceilometer-common-2014.2.3-5.el7ost.noarch
python-ceilometer-2014.2.3-5.el7ost.noarch
openstack-ceilometer-notification-2014.2.3-5.el7ost.noarch
openstack-ceilometer-central-2014.2.3-5.el7ost.noarch
openstack-ceilometer-api-2014.2.3-5.el7ost.noarch
openstack-ceilometer-alarm-2014.2.3-5.el7ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. Deploy an all-in-one using packstack
2. Launch an instance and the error message will be output every 10 minutes


Expected results:

Those messages shouldn't be output.

Additional info:
Comment 3 Benjamin Schmaus 2015-08-10 20:56:47 EDT
We are seeing the same behavior in OSP6 on RHEL7:

2015-07-27 09:17:12.301 54276 ERROR ceilometer.hardware.discovery [-] Couldn't obtain IP address ofinstance <ID of Instance>
2015-07-27 09:17:12.301 54276 ERROR ceilometer.hardware.discovery [-] Couldn't obtain IP address ofinstance <ID of Instance>

Environment uses flat VLAN configuration.
Comment 5 Shinobu KINJO 2015-10-16 03:47:54 EDT
There are still same bugs. Has the patch already been released?
Comment 6 Shinobu KINJO 2015-10-16 03:51:19 EDT
FYI:
The Ceilometers RPM versions customer using now:

openstack-ceilometer-alarm-2014.2.3-5.el7ost.noarch
openstack-ceilometer-api-2014.2.3-5.el7ost.noarch
openstack-ceilometer-central-2014.2.3-5.el7ost.noarch
openstack-ceilometer-collector-2014.2.3-5.el7ost.noarch
openstack-ceilometer-common-2014.2.3-5.el7ost.noarch
openstack-ceilometer-notification-2014.2.3-5.el7ost.noarch
python-ceilometer-2014.2.3-5.el7ost.noarch
python-ceilometerclient-1.0.12-1.el7ost.noarch
Comment 7 Shinobu KINJO 2015-10-16 04:38:04 EDT
Customer is using Keystone V3 API.
Comment 12 Mehdi ABAAKOUK 2016-11-28 08:11:23 EST
Keystone V3 is supported by Ceilometer only since OSP9, and the patch is impossible to backport to older version.
Comment 13 Mehdi ABAAKOUK 2016-11-28 08:15:15 EST

*** This bug has been marked as a duplicate of bug 1283014 ***

Note You need to log in before you can comment on or make changes to this bug.