Bug 1250440 - media check times out when booting physical DVD
media check times out when booting physical DVD
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint-list
Fedora Extras Quality Assurance
AcceptedBlocker https://fedoraproject...
: CommonBugs
Depends On:
Blocks: F23FinalBlocker
  Show dependency treegraph
 
Reported: 2015-08-05 07:14 EDT by Kamil Páral
Modified: 2015-10-01 10:12 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-01 10:12:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of media check timeout (765.97 KB, image/jpeg)
2015-08-05 07:14 EDT, Kamil Páral
no flags Details
screenshot of media check complete (768.43 KB, image/jpeg)
2015-08-05 07:15 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2015-08-05 07:14:49 EDT
Created attachment 1059434 [details]
screenshot of media check timeout

Description of problem:
I have burned F22 Alpha RC1 Workstation Live onto DVD and tried to boot it. The boot process timed out during media check, and after the check was complete, only the dracut emergency shell was available. The boot process did not resume.

There seems to be some wrong configuration of the services, and they do not wait for the media check to complete, regardless of how long it takes. On physical CDs/DVDs, it can take a long time. The time out seems to occur after 90 seconds.

Version-Release number of selected component (if applicable):
F23 Alpha RC1 Workstation Live

How reproducible:
always

Steps to Reproduce:
1. burn Live onto DVD (other media are currently affected by bug 1250414)
2. perform a media check (it should take more than 90 seconds to trigger this, I've hit it every time around 30% of check completed)
Comment 1 Kamil Páral 2015-08-05 07:15:46 EDT
Created attachment 1059435 [details]
screenshot of media check complete

After the check is complete, the boot does not resume. If you press Enter, you'll get a prompt for the rescue shell.
Comment 2 Kamil Páral 2015-08-05 07:19:45 EDT
Proposing as a blocker. This is in a strict sense violation of the following basic criterion:
"The installer must run when launched normally from the release-blocking images."
https://fedoraproject.org/wiki/Fedora_23_Alpha_Release_Criteria#Installer_must_run

The media check is the default boot action for UEFI (but not for BIOS) mode, so people running physical DVDs over UEFI will not get into anaconda by default. However, since this a bit of an edge case (physical DVDs) and easy to work around (run without a media check), I think it would be OK the move this to Beta or Final. One of other applicable criteria is:
"Validation of install media must work correctly for all release-blocking images. "
https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria#Media_consistency_verification
Comment 3 Stephen Gallagher 2015-08-05 09:25:01 EDT
I'm -1 blocker to anything involving the media check, considering it hasn't worked properly for multiple releases on EFI. I think we need to revoke that criteria since we have consistently been letting it slide anyhow.
Comment 4 Kamil Páral 2015-08-05 10:30:58 EDT
Stephen, can you be please more specific? As far as I know, there were occasional issues, but we always fixed them, and everything just worked (tm). This particular bug is not present on F22 Live media, I just checked, so it seems to be a F23 regression. Also, this is not anyhow specific to UEFI. I just noted that media verification is the default boot option on UEFI. But it affects BIOS mode as well.
Comment 5 Zbigniew Jędrzejewski-Szmek 2015-08-05 10:46:47 EDT
The error is:
Checking: 032.9%[ TIME ] Time out waiting for device dev-mapper-live\x2drw.device.
[DEPEND] Dependency failed for /sysroot
[DEPEND] Dependency failed for Initrd Root File System.
[DEPEND] Dependency failed for Reload Configuration from the Real Root.

It looks like Timeout=0 (Timeout=15 min?) should be added.
Comment 6 Stephen Gallagher 2015-08-05 10:48:34 EDT
(In reply to Kamil Páral from comment #4)
> Stephen, can you be please more specific? As far as I know, there were
> occasional issues, but we always fixed them, and everything just worked
> (tm). This particular bug is not present on F22 Live media, I just checked,
> so it seems to be a F23 regression. Also, this is not anyhow specific to
> UEFI. I just noted that media verification is the default boot option on
> UEFI. But it affects BIOS mode as well.

Sorry, that was a general comment that the media check has not been terribly well-maintained in the past.

On Fedora 22 media, if you boot via UEFI, the media check just simply never works. It always returns an error, regardless of the state of the media. This was noted and ignored back then. I was going to file a bug on it, but someone (I forget who) told me it was a well-known issue.
Comment 7 Kamil Páral 2015-08-05 10:54:25 EDT
(In reply to Stephen Gallagher from comment #6)
> On Fedora 22 media, if you boot via UEFI, the media check just simply never
> works. It always returns an error, regardless of the state of the media.
> This was noted and ignored back then. I was going to file a bug on it, but
> someone (I forget who) told me it was a well-known issue.

Hmm, it just worked for me (burned DVD). Are you sure you're not talking about ISO->USB converted media with other tools than dd? That doesn't work (both BIOS and UEFI), AFAIK.
Comment 8 Stephen Gallagher 2015-08-05 11:10:08 EDT
Well, I always use either 'dd' or gnome-multiwriter to create USB sticks (the latter essentially doing dd under the hood). So maybe that's what I was remembering.
Comment 9 Adam Williamson 2015-08-05 12:12:50 EDT
The Final criterion is clearly the one meant to cover this case, it seems an unjustifiable stretch to try and say the "installer must run" criterion covers it. That criterion does not say that it must run without the user moving the menu selection. -1 Alpha, +1 Final.
Comment 10 Stephen Gallagher 2015-08-05 12:48:00 EDT
To be clear, I'm still -1 Alpha. I'm fine with a Final blocker.
Comment 11 Mike Ruckman 2015-08-05 12:48:38 EDT
-1 Alpha, +1 Final
Comment 12 Kevin Fenzi 2015-08-05 13:02:55 EDT
-1 Alpha, +1 Final.
Comment 13 Adam Williamson 2015-08-05 13:46:27 EDT
Marking as accepted Final blocker with +4. Not proposing as Alpha FE for now as we're still trying to hit Thursday, if we slip we might consider adding a fix I guess.
Comment 15 Adam Williamson 2015-09-30 18:38:25 EDT
I believe this should in fact be fixed in current F23: the fix was in https://bodhi.fedoraproject.org/updates/FEDORA-2015-13298 by the looks of it. Kamil, can you re-test with Final TC1? Thanks!
Comment 16 Kamil Páral 2015-10-01 10:12:03 EDT
This is indeed fixed, verified with F23 TC1 Workstation Live, both BIOS and UEFI mode.

Note You need to log in before you can comment on or make changes to this bug.