Bug 1250599 - openstack-nova requires python-oslo-serialization
openstack-nova requires python-oslo-serialization
Status: CLOSED DUPLICATE of bug 1266956
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
nlevinki
:
Depends On:
Blocks: track-osp6-osp7 1266956
  Show dependency treegraph
 
Reported: 2015-08-05 10:18 EDT by Lars Kellogg-Stedman
Modified: 2015-09-28 12:23 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 12:23:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2015-08-05 10:18:42 EDT
openstack-nova in OSP 7 requires python-oslo-serialization.  After upgrading from OSP 6, running nova-manage db sync fails with:

stderr: Traceback (most recent call last):
  File "/usr/bin/nova-manage", line 6, in <module>
    from nova.cmd.manage import main
  File "/usr/lib/python2.7/site-packages/nova/cmd/manage.py", line 65, in <module>
    from oslo_log import log as logging
  File "/usr/lib/python2.7/site-packages/oslo_log/log.py", line 47, in <module>
    from oslo_log import formatters
  File "/usr/lib/python2.7/site-packages/oslo_log/formatters.py", line 24, in <module>
    from oslo_serialization import jsonutils
ImportError: No module named oslo_serialization
Can't determine the existing sync level.
Please ensure the database is running and already initialised.

In version:

openstack-nova-common-2015.1.0-16.el7ost.noarch
Comment 3 Lars Kellogg-Stedman 2015-09-28 12:23:50 EDT
Rolled into #1266956

*** This bug has been marked as a duplicate of bug 1266956 ***

Note You need to log in before you can comment on or make changes to this bug.