Bug 1250604 - openstack-nova requires python-oslo-messaging
openstack-nova requires python-oslo-messaging
Status: CLOSED DUPLICATE of bug 1266956
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
nlevinki
:
Depends On:
Blocks: track-osp6-osp7 1266956
  Show dependency treegraph
 
Reported: 2015-08-05 10:32 EDT by Lars Kellogg-Stedman
Modified: 2015-09-28 12:24 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 12:24:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2015-08-05 10:32:19 EDT
openstack-nova in OSP 7 requires python-oslo-messaging. After upgrading from OSP 6, running nova-manage db sync fails with:

stderr: Traceback (most recent call last):
  File "/usr/bin/nova-manage", line 6, in <module>
    from nova.cmd.manage import main
  File "/usr/lib/python2.7/site-packages/nova/cmd/manage.py", line 66, in <module>
    import oslo_messaging as messaging
ImportError: No module named oslo_messaging
Can't determine the existing sync level.
Please ensure the database is running and already initialised.

In version:

openstack-nova-common-2015.1.0-16.el7ost.noarch
Comment 3 Lars Kellogg-Stedman 2015-09-28 12:24:02 EDT
Rolled into #1266956.

*** This bug has been marked as a duplicate of bug 1266956 ***

Note You need to log in before you can comment on or make changes to this bug.