Bug 1250609 - openstack-nova requires python-oslo-rootwrap
openstack-nova requires python-oslo-rootwrap
Status: CLOSED DUPLICATE of bug 1266956
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
nlevinki
:
Depends On:
Blocks: track-osp6-osp7 1266956
  Show dependency treegraph
 
Reported: 2015-08-05 10:41 EDT by Lars Kellogg-Stedman
Modified: 2015-09-28 12:24 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 12:24:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2015-08-05 10:41:03 EDT
openstack-nova in OSP 7 requires python-oslo-rootwrap.  After upgrading from OSP 6, the nova-api service will fail with:

CRITICAL nova [-] ProcessExecutionError: Unexpected error while running command.
Command: sudo nova-rootwrap /etc/nova/rootwrap.conf iptables-save -c
Exit code: 1
Stdout: u''
Stderr: u'Traceback (most recent call last):\n  File "/usr/bin/nova-rootwrap", line 6, in <module>\n    from oslo_rootwrap
.cmd import main\nImportError: No module named oslo_rootwrap.cmd\n'
TRACE nova Traceback (most recent call last):
TRACE nova   File "/usr/bin/nova-api", line 10, in <module>
TRACE nova     sys.exit(main())
TRACE nova   File "/usr/lib/python2.7/site-packages/nova/cmd/api.py", line 55, in main
TRACE nova     server = service.WSGIService(api, use_ssl=should_use_ssl)
TRACE nova   File "/usr/lib/python2.7/site-packages/nova/service.py", line 333, in __init__
TRACE nova     self.manager = self._get_manager()
TRACE nova   File "/usr/lib/python2.7/site-packages/nova/service.py", line 390, in _get_manager
TRACE nova     return manager_class()
TRACE nova   File "/usr/lib/python2.7/site-packages/nova/api/manager.py", line 30, in __init__
TRACE nova     self.network_driver.metadata_accept()
TRACE nova   File "/usr/lib/python2.7/site-packages/nova/network/linux_net.py", line 700, in metadata_accept
TRACE nova     iptables_manager.apply()
TRACE nova   File "/usr/lib/python2.7/site-packages/nova/network/linux_net.py", line 442, in apply
TRACE nova     self._apply()
TRACE nova   File "/usr/lib/python2.7/site-packages/oslo_concurrency/lockutils.py", line 445, in inner
TRACE nova     return f(*args, **kwargs)
TRACE nova   File "/usr/lib/python2.7/site-packages/nova/network/linux_net.py", line 462, in _apply
TRACE nova     attempts=5)
TRACE nova   File "/usr/lib/python2.7/site-packages/nova/network/linux_net.py", line 1266, in _execute
TRACE nova     return utils.execute(*cmd, **kwargs)
TRACE nova   File "/usr/lib/python2.7/site-packages/nova/utils.py", line 213, in execute
TRACE nova     return processutils.execute(*cmd, **kwargs)
TRACE nova   File "/usr/lib/python2.7/site-packages/oslo_concurrency/processutils.py", line 233, in execute
TRACE nova     cmd=sanitized_cmd)
TRACE nova ProcessExecutionError: Unexpected error while running command.
TRACE nova Command: sudo nova-rootwrap /etc/nova/rootwrap.conf iptables-save -c
TRACE nova Exit code: 1
TRACE nova Stdout: u''
TRACE nova Stderr: u'Traceback (most recent call last):\n  File "/usr/bin/nova-rootwrap", line 6, in <module>\n    from oslo_rootwrap.cmd import main\nImportError: No module named oslo_rootwrap.cmd\n'

In version:

openstack-nova-api-2015.1.0-16.el7ost.noarch
Comment 3 Lars Kellogg-Stedman 2015-09-28 12:24:30 EDT
Rolled into #1266956.

*** This bug has been marked as a duplicate of bug 1266956 ***

Note You need to log in before you can comment on or make changes to this bug.