Bug 1250737 - systemd-tmpfiles-setup.service fails on 23 Alpha RC1 Server
systemd-tmpfiles-setup.service fails on 23 Alpha RC1 Server
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 1259836 (view as bug list)
Depends On:
Blocks: F23FinalBlocker
  Show dependency treegraph
 
Reported: 2015-08-05 16:55 EDT by Adam Williamson
Modified: 2015-10-07 03:42 EDT (History)
10 users (show)

See Also:
Fixed In Version: 222-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 00:08:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2015-08-05 16:55:37 EDT
To reproduce: do a clean install of Fedora 23 Alpha RC1 Server DVD and boot it.

Result: systemd-tmpfiles-setup.service fails. Errors:

● systemd-tmpfiles-setup.service - Create Volatile Files and Directories
   Loaded: loaded (/usr/lib/systemd/system/systemd-tmpfiles-setup.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2015-08-05 15:43:43 CDT; 10min ago
     Docs: man:tmpfiles.d(5)
           man:systemd-tmpfiles(8)
  Process: 672 ExecStart=/usr/bin/systemd-tmpfiles --create --remove --boot --exclude-prefix=/dev (code=exited, status=1/FAILURE)
 Main PID: 672 (code=exited, status=1/FAILURE)

Aug 05 15:43:43 localhost.localdomain systemd[1]: Starting Create Volatile Files and Directories...
Aug 05 15:43:43 localhost.localdomain systemd-tmpfiles[672]: Cannot set file attribute for '/var/log/journal', value=0x00800000, mask=0x00800000: Operation not supported
Aug 05 15:43:43 localhost.localdomain systemd-tmpfiles[672]: Cannot set file attribute for '/var/log/journal/eff7c9e8dff0458fab61d63c4aa40e43', value=0x00800000, mask=0x00800000: Operation not supported
Aug 05 15:43:43 localhost.localdomain systemd[1]: systemd-tmpfiles-setup.service: Main process exited, code=exited, status=1/FAILURE
Aug 05 15:43:43 localhost.localdomain systemd[1]: Failed to start Create Volatile Files and Directories.
Aug 05 15:43:43 localhost.localdomain systemd[1]: systemd-tmpfiles-setup.service: Unit entered failed state.
Aug 05 15:43:43 localhost.localdomain systemd[1]: systemd-tmpfiles-setup.service: Failed with result 'exit-code'.

This could perhaps be to do with Server using xfs for /?

Proposing as a Final blocker: "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present." - https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria#System_services
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-08-05 21:34:43 EDT
This is because of XFS. Apparently every filesystem behaves differently.
Downgraded to a warning in https://github.com/systemd/systemd/issues/560.
Comment 2 Adam Williamson 2015-08-20 13:57:41 EDT
Discussed at 2015-08-20 blocker review meeting: http://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-08-20/f23-blocker-review.2015-08-20-16.05.log.txt . Accepted as a blocker per criterion cited in description.

Note: we are generally of the opinion that 'carry on failing, but call it a warning instead of an error' is not a good fix here. tmpfiles exists for a reason, it not working properly would appear to be something of a problem.
Comment 3 Petr Schindler 2015-09-16 04:28:45 EDT
This still happens with Beta RC1 Server (DVD).
Comment 4 Adam Williamson 2015-09-17 02:55:41 EDT
Yeah, indeed.
Comment 5 Fedora Update System 2015-09-18 08:40:00 EDT
systemd-222-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16155
Comment 6 Fedora Update System 2015-09-18 10:46:13 EDT
systemd-222-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16165
Comment 7 Fedora Update System 2015-09-18 20:20:35 EDT
systemd-222-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update systemd'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16165
Comment 8 Fedora Update System 2015-09-23 00:08:06 EDT
systemd-222-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Jan Synacek 2015-10-07 03:42:16 EDT
*** Bug 1259836 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.