Bug 1259836 - systemd-tmpfiles-setup.service failed: Operation not permitted
systemd-tmpfiles-setup.service failed: Operation not permitted
Status: CLOSED DUPLICATE of bug 1250737
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 11:17 EDT by Christian Stadelmann
Modified: 2015-10-07 03:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-07 03:42:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2015-09-03 11:17:42 EDT
Description of problem:
On a fresh default F23 Alpha installation after some reboots `systemctl status` shows that the unit file systemd-tmpfiles-setup.service has failed.

$ systemctl status -l systemd-tmpfiles-setup.service 
● systemd-tmpfiles-setup.service - Create Volatile Files and Directories
   Loaded: loaded (/usr/lib/systemd/system/systemd-tmpfiles-setup.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Do 2015-09-03 16:46:11 CEST; 23min ago
     Docs: man:tmpfiles.d(5)
           man:systemd-tmpfiles(8)
  Process: 1067 ExecStart=/usr/bin/systemd-tmpfiles --create --remove --boot --exclude-prefix=/dev (code=exited, status=1/FAILURE)
 Main PID: 1067 (code=exited, status=1/FAILURE)

Sep 03 16:46:11 hostname systemd[1]: Starting Create Volatile Files and Directories...
Sep 03 16:46:11 hostname systemd-tmpfiles[1067]: rm_rf(/var/tmp/dnf-username-u0yz366f/locks/9777ed853bf3f1804d119c362700ca23): Operation not permitted
Sep 03 16:46:11 hostname systemd-tmpfiles[1067]: rm_rf(/var/tmp/dnf-abrt-93ep4jy_/locks/401341be3cefb59697dfc16a3b847f3d): Operation not permitted
Sep 03 16:46:11 hostname systemd[1]: systemd-tmpfiles-setup.service: Main process exited, code=exited, status=1/FAILURE
Sep 03 16:46:12 hostname systemd[1]: Failed to start Create Volatile Files and Directories.
Sep 03 16:46:12 hostname systemd[1]: systemd-tmpfiles-setup.service: Unit entered failed state.
Sep 03 16:46:12 hostname systemd[1]: systemd-tmpfiles-setup.service: Failed with result 'exit-code'

Version-Release number of selected component (if applicable):
systemd-222-2.fc23.x86_64
Comment 1 Jan Synacek 2015-10-07 03:42:16 EDT

*** This bug has been marked as a duplicate of bug 1250737 ***

Note You need to log in before you can comment on or make changes to this bug.