Bug 1250828 - Tiering: segfault when trying to rename a file
Tiering: segfault when trying to rename a file
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Reopened, Triaged
Depends On:
Blocks: 1254438 1260923
  Show dependency treegraph
 
Reported: 2015-08-06 02:06 EDT by Mohammed Rafi KC
Modified: 2016-06-16 09:28 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1254438 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:28:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2015-08-06 02:06:43 EDT
Description of problem:

On a tier volume with both cold and hot tiers as pure distribute, when trying to move a promoted/demoted file, mount process crashed (if build with debug enable, other wise assertion failure).

Version-Release number of selected component (if applicable):

mainline

How reproducible:

100%

Steps to Reproduce:
1.create a tier volume (cold and hot tier as pure distribute)
2.create some file on mount point
3.let some files promote/demote
4.rename a promoted/demoted file

Actual results:

mount crash

Expected results:

mount should not crash

Additional info:

binary's are build with --debug-enable flag
Comment 1 Mohammed Rafi KC 2015-08-06 02:08:32 EDT
when creating a link file, dictionary used for passing xattributes contains some keys used for lookup.
Comment 2 Anand Avati 2015-08-06 02:12:19 EDT
REVIEW: http://review.gluster.org/11838 (dht/tiering : create new dictionary during migration) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 3 Anand Avati 2015-08-06 09:01:50 EDT
COMMIT: http://review.gluster.org/11838 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit a3faffb259d5288907fac33a2822a8f61c3e86fe
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Wed Aug 5 19:34:01 2015 +0530

    dht/tiering : create new dictionary during migration
    
    To avoid setting wrong xattr during creating link file
    
    Change-Id: Iad8de3521eae17e510035ed42e3e01933d647096
    BUG: 1250828
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11838
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 4 Nagaprasad Sathyanarayana 2015-10-25 10:54:19 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 5 Niels de Vos 2016-06-16 09:28:57 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.