Bug 1254438 - Tiering: segfault when trying to rename a file
Tiering: segfault when trying to rename a file
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.3
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Triaged
Depends On: 1250828
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-08-18 03:16 EDT by Mohammed Rafi KC
Modified: 2015-10-30 13:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1250828
Environment:
Last Closed: 2015-09-09 05:39:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2015-08-18 03:16:49 EDT
+++ This bug was initially created as a clone of Bug #1250828 +++

Description of problem:

On a tier volume with both cold and hot tiers as pure distribute, when trying to move a promoted/demoted file, mount process crashed (if build with debug enable, other wise assertion failure).

Version-Release number of selected component (if applicable):

mainline

How reproducible:

100%

Steps to Reproduce:
1.create a tier volume (cold and hot tier as pure distribute)
2.create some file on mount point
3.let some files promote/demote
4.rename a promoted/demoted file

Actual results:

mount crash

Expected results:

mount should not crash

Additional info:

binary's are build with --debug-enable flag

--- Additional comment from Mohammed Rafi KC on 2015-08-06 02:08:32 EDT ---

when creating a link file, dictionary used for passing xattributes contains some keys used for lookup.

--- Additional comment from Anand Avati on 2015-08-06 02:12:19 EDT ---

REVIEW: http://review.gluster.org/11838 (dht/tiering : create new dictionary during migration) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-06 09:01:50 EDT ---

COMMIT: http://review.gluster.org/11838 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit a3faffb259d5288907fac33a2822a8f61c3e86fe
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Wed Aug 5 19:34:01 2015 +0530

    dht/tiering : create new dictionary during migration
    
    To avoid setting wrong xattr during creating link file
    
    Change-Id: Iad8de3521eae17e510035ed42e3e01933d647096
    BUG: 1250828
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11838
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 1 Anand Avati 2015-08-18 06:37:23 EDT
REVIEW: http://review.gluster.org/11945 (dht/tiering : create new dictionary during migration) posted (#2) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Anand Avati 2015-08-20 02:38:54 EDT
COMMIT: http://review.gluster.org/11945 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit d776cfb85e00fe0a03e7c13c903f453ff201e73f
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Wed Aug 5 19:34:01 2015 +0530

    dht/tiering : create new dictionary during migration
    
    To avoid setting wrong xattr during creating link file
    
    Back port of:
    >Change-Id: Iad8de3521eae17e510035ed42e3e01933d647096
    >BUG: 1250828
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/11838
    >Reviewed-by: N Balachandran <nbalacha@redhat.com>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    (cherry picked from commit a3faffb259d5288907fac33a2822a8f61c3e86fe)
    
    Change-Id: I76ef168cd881c8fd828283a1ae70ed251fc44aaa
    BUG: 1254438
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11945
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2015-09-09 05:39:53 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.