Bug 1250854 - [WHQL][vioscsi]The job named crash dump failed on windows 2008 -32/64 platform
Summary: [WHQL][vioscsi]The job named crash dump failed on windows 2008 -32/64 platform
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337
TreeView+ depends on / blocked
 
Reported: 2015-08-06 07:25 UTC by Min Deng
Modified: 2016-11-04 08:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:48:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
Logs (29 bytes, application/x-gzip)
2015-08-06 07:26 UTC, Min Deng
no flags Details
win2008-64-108-scsi wlk log (1.78 MB, application/vnd.ms-cab-compressed)
2015-08-07 10:12 UTC, lijin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Min Deng 2015-08-06 07:25:29 UTC
Description of problem:
The job named crash dump failed on windows 2008 -32/64 platform

Version-Release number of selected component (if applicable):
kernel-3.10.0-300.el7.x86_64
qemu-kvm-rhev-2.3.0-13.el7.x86_64
seabios-1.7.5-11.el7.x86_64
virti-win-prewhql-0.1-108

How reproducible:
10 times

Steps to Reproduce:
1.boot up guest 
  /usr/libexec/qemu-kvm -name 108SCS200864RU3 -enable-kvm -m 4G -smp 4 -uuid 8316f6fe-9876-4797-854d-648f8ab66fca -nodefconfig -nodefaults -cpu Nehalem,+fsgsbase -chardev socket,id=charmonitor,path=/tmp/108SCS200864RU3,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-scsi-pci,id=scsi1,bus=pci.0,addr=0x9 -device scsi-hd,bus=scsi1.0,drive=drive-ide0-0-0,id=scsi-disk1,bootindex=1 -drive file=108SCS200864RU3,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -drive file=en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=108SCS200864RU3.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:2c:45:83:2b,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x7 -drive file=108SCS200864RU3_test.raw,if=none,id=drive-scsi-disk0,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi0.0,drive=drive-scsi-disk0,id=scsi-disk0 -monitor stdio
2.submit the job named 'CrashDump Support Test' on system disk

Actual results:
The job could not pass.
*It is because that the complete dump could not be generated*
Expected results:
The job could pass.

Additional info:
It is not reproduced via build 105 and QE will provide logs to the bug right now.

Comment 1 Min Deng 2015-08-06 07:26:30 UTC
Created attachment 1059745 [details]
Logs

Comment 3 lijin 2015-08-07 10:12:01 UTC
Created attachment 1060323 [details]
win2008-64-108-scsi wlk log

Comment 4 lijin 2015-08-07 10:13:12 UTC
Hi Vadim
I have upload the log again,please have a look.

Comment 5 Vadim Rozenfeld 2015-08-07 11:45:54 UTC
(In reply to lijin from comment #4)
> Hi Vadim
> I have upload the log again,please have a look.

thanks a lot.
Does it happens in single-queue mode only or in mq as well?

Comment 6 Min Deng 2015-08-10 05:29:03 UTC
(In reply to Vadim Rozenfeld from comment #5)
> (In reply to lijin from comment #4)
> > Hi Vadim
> > I have upload the log again,please have a look.
> 
> thanks a lot.
> Does it happens in single-queue mode only or in mq as well?

Vadim,
    It happens on singel-queue and QE could not verify this job as it was blocked by 1249867.Any issues please let me know,thanks !

Best Regards,
Min

Comment 7 Vadim Rozenfeld 2015-08-10 05:54:21 UTC
(In reply to dengmin from comment #6)
> (In reply to Vadim Rozenfeld from comment #5)
> > (In reply to lijin from comment #4)
> > > Hi Vadim
> > > I have upload the log again,please have a look.
> > 
> > thanks a lot.
> > Does it happens in single-queue mode only or in mq as well?
> 
> Vadim,
>     It happens on singel-queue and QE could not verify this job as it was
> blocked by 1249867.Any issues please let me know,thanks !
> 
> Best Regards,
> Min

Thanks Min,
Could you please try build 109, available at 
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/109/win/virtio-win-prewhql-0.1.zip ?

Best regards,
Vadim.

Comment 8 Min Deng 2015-08-10 13:39:21 UTC
(In reply to Vadim Rozenfeld from comment #7)
> (In reply to dengmin from comment #6)
> > (In reply to Vadim Rozenfeld from comment #5)
> > > (In reply to lijin from comment #4)
> > > > Hi Vadim
> > > > I have upload the log again,please have a look.
> > > 
> > > thanks a lot.
> > > Does it happens in single-queue mode only or in mq as well?
> > 
> > Vadim,
> >     It happens on singel-queue and QE could not verify this job as it was
> > blocked by 1249867.Any issues please let me know,thanks !
> > 
> > Best Regards,
> > Min
> 
> Thanks Min,
> Could you please try build 109, available at 
> http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/
> 109/win/virtio-win-prewhql-0.1.zip ?
> 
> Best regards,
> Vadim.

Hi Vadim,

  Re-tested the bug via above build and find the job could pass finally.So the issue has been fixed on build 109,thanks in advance.

Best Regards
Min

Comment 10 lijin 2015-09-11 05:23:15 UTC
change status to verified according to comment#8

Comment 11 Vadim Rozenfeld 2015-09-30 06:07:33 UTC
This bug is tightly coupled with https://bugzilla.redhat.com/show_bug.cgi?id=1210166 
Moving it to 7.3 as well.

Comment 13 Yu Wang 2016-07-08 07:30:44 UTC
Re-test this bug with virtio-win-prewhql-120(with virtio1.0 device), the job could pass .So the issue has been fixed on build 120.

Thanks
Yu Wang

Comment 14 Yu Wang 2016-07-08 07:31:37 UTC
According to comment#13, change status to verified.

Comment 16 errata-xmlrpc 2016-11-04 08:48:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.