Bug 1250925 - Change the requirement for the RHEL image to 6.7
Change the requirement for the RHEL image to 6.7
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: sahara-image-elements (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: z3
: 7.0 (Kilo)
Assigned To: Elise Gafford
Luigi Toscano
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 06:16 EDT by Luigi Toscano
Modified: 2015-12-21 12:09 EST (History)
4 users (show)

See Also:
Fixed In Version: sahara-image-elements-2015.1.0-4.el7ost
Doc Type: Bug Fix
Doc Text:
Previous versions of sahara-disk-image-create accepted the tested RHEL image version 6.6. However, this version has been soft-deprecated in favor of RHEL 6.7, which has been tested successfully. With this update, any RHEL 6 guest images are accepted.
Story Points: ---
Clone Of:
: 1250930 (view as bug list)
Environment:
Last Closed: 2015-12-21 12:09:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luigi Toscano 2015-08-06 06:16:29 EDT
Description of problem:
sahara-disk-image-create expects to find the RHEL6.6 cloud image. Now that RHEL 6.7 is released, it should be used instead.

The fix itself in the script is trivial, testing could require a bit more time.

Version-Release number of selected component (if applicable):
sahara-image-elements-2015.1.0-3.el7ost.noarch
Comment 3 Elise Gafford 2015-10-01 18:08:49 EDT
Fixed per PM/QE/dev discussion: opened precondition regex to all RHEL 6 guest image versions.
Comment 5 Luigi Toscano 2015-12-07 07:34:21 EST
Images based on rhel-guest-image-6.7-20150706.0.x86_64.qcow2 can be properly generated for both supported plugins and integration tests ("scenario") pass:

sahara-image-elements-2015.1.0-5.el7ost.noarch
diskimage-builder-0.1.46-4.el7ost.noarch
dib-utils-0.0.9-1.el7ost.noarch

Server side:
python-saharaclient-0.9.0-1.el7ost.noarch
openstack-sahara-api-2015.1.2-1.el7ost.noarch
openstack-sahara-engine-2015.1.2-1.el7ost.noarch
openstack-sahara-common-2015.1.2-1.el7ost.noarch
Comment 7 errata-xmlrpc 2015-12-21 12:09:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2674

Note You need to log in before you can comment on or make changes to this bug.