Bug 1250930 - Change the requirement for the RHEL image to 6.7
Change the requirement for the RHEL image to 6.7
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: sahara-image-elements (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
high Severity unspecified
: async
: 6.0 (Juno)
Assigned To: Elise Gafford
Luigi Toscano
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 06:30 EDT by Luigi Toscano
Modified: 2016-06-23 14:37 EDT (History)
4 users (show)

See Also:
Fixed In Version: sahara-image-elements-2014.2-5.el7ost
Doc Type: Bug Fix
Doc Text:
Cause: Previous versions of package accepted the tested RHEL image version 6.6. However, this version was soft-deprecated in favor of RHEL 6.7 (which has now been tested successfully with this package). Consequence: Current image version was rejected by script preconditions (though it succeeded if preconditions were forcibly ignored.) Fix: Opened precondition to accept any RHEL 6 guest image. Result: Current RHEL 6 guest image passes precondition and builds images successfully.
Story Points: ---
Clone Of: 1250925
Environment:
Last Closed: 2016-06-23 14:37:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luigi Toscano 2015-08-06 06:30:35 EDT
+++ This bug was initially created as a clone of Bug #1250925 +++

Description of problem:
sahara-disk-image-create expects to find the RHEL6.6 cloud image. Now that RHEL 6.7 is released, it should be used instead.

The fix itself in the script is trivial, testing could require a bit more time.

Version-Release number of selected component (if applicable):
sahara-image-elements-2015.1.0-3.el7ost.noarch
Comment 1 Luigi Toscano 2015-08-06 06:31:20 EDT
The version for the package in RHEL-OSP6 is:
sahara-image-elements-2014.2-4.el7ost.noarch
Comment 2 Elise Gafford 2015-10-01 17:33:58 EDT
Fixed per PM/QE/dev discussion: opened precondition regex to all RHEL 6 guest image versions.
Comment 4 Luigi Toscano 2016-06-20 12:48:33 EDT
The sahara-disk-image-create now supports any RHEL 6.x image which is available in the directory where the command is executed (6.8 was used for testing).

Verified with:
sahara-image-elements-2014.2-5.el7ost.noarch
diskimage-builder-0.1.34-21.el7ost.noarch
dib-utils-0.0.8-1.el7ost.noarch
Comment 6 errata-xmlrpc 2016-06-23 14:37:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1316

Note You need to log in before you can comment on or make changes to this bug.