Bug 1251027 - lightdm-1.10.5 failed
lightdm-1.10.5 failed
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: lightdm (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
http://lists.freedesktop.org/archives...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 08:39 EDT by poma
Modified: 2015-09-01 14:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 14:47:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Connection add failed (327.20 KB, image/png)
2015-08-06 08:49 EDT, poma
no flags Details
loginctl list-sessions (266.10 KB, image/png)
2015-08-12 18:18 EDT, poma
no flags Details
Connection add failed 2 (346.29 KB, image/png)
2015-08-23 06:52 EDT, poma
no flags Details
session details when booting, and after log out/log in (2.10 KB, text/plain)
2015-08-25 04:09 EDT, Jirka Klimes
no flags Details

  None (edit)
Description poma 2015-08-06 08:39:54 EDT
Description of problem:

Connection add failed.

Version-Release number of selected component (if applicable):

NetworkManager Applet
1.0.4

How reproducible:

Thursdays, Fridays, sometimes on Mondays.

Steps to Reproduce:
1.Via network control and status applet for NetworkManager
2.Edit Connections... / Add / Create...
3.Save

Actual results:

Connection add failed
No session found for uid 1000 (unknown)

Expected results:

Connection add successfully.


Additional info:
Comment 1 poma 2015-08-06 08:49:17 EDT
Created attachment 1059930 [details]
Connection add failed
Comment 2 Jirka Klimes 2015-08-10 06:41:40 EDT
(In reply to poma from comment #0)
> How reproducible:
> 
> Thursdays, Fridays, sometimes on Mondays.
> 
;-)

> Actual results:
> 
> Connection add failed
> No session found for uid 1000 (unknown)
> 
Can you get NetworkManager logs when you hit the issue?
Do you have a proper logind session registered? What's the output of
loginctl list-sessions
loginctl session-status <session id>
Comment 3 poma 2015-08-12 18:18:16 EDT
Created attachment 1062285 [details]
loginctl list-sessions

NM works but liveuser can't manage.
Comment 4 poma 2015-08-22 06:33:24 EDT
Dan Williams, Jirka Klimes and Lubomir Rintel do not help at all.
Comment 5 poma 2015-08-22 06:38:34 EDT
Let's see whether Kevin Fenzi, Mukundan Ragavan, Christoph Wickert or Rex Dieter would be of any help.
Comment 6 poma 2015-08-23 06:52:25 EDT
Created attachment 1066021 [details]
Connection add failed 2
Comment 7 poma 2015-08-23 06:53:37 EDT
What's up Wolfgang
Comment 8 Wolfgang Ulbrich 2015-08-23 09:05:54 EDT
Hmm, i'm able to create a network connection with nm-applet as liveuser.
Tested with latest mate nightly build from today and network-manager-applet-1.4.0-2.
http://koji.fedoraproject.org/koji/taskinfo?taskID=10795666
I'm using qemu-kvm with virtual-manager.
Comment 9 Wolfgang Ulbrich 2015-08-23 09:08:07 EDT
Thursdays, Fridays, sometimes on Mondays.
:)
Ok, i will test this.
Comment 10 poma 2015-08-23 12:08:09 EDT
Thanks for testing,
see if you can reproduce via DHCP server static lease hostnamed "fedora2364", for your virtual machine.
Comment 11 Wolfgang Ulbrich 2015-08-24 06:11:50 EDT
(In reply to poma from comment #10)
> Thanks for testing,
> see if you can reproduce via DHCP server static lease hostnamed
> "fedora2364", for your virtual machine.

I use the the builtin dhcp server, here i can't configure a static lease.
Comment 12 poma 2015-08-24 12:21:16 EDT
(In reply to Wolfgang Ulbrich from comment #11)
> (In reply to poma from comment #10)
> > Thanks for testing,
> > see if you can reproduce via DHCP server static lease hostnamed
> > "fedora2364", for your virtual machine.
> 
> I use the the builtin dhcp server, here i can't configure a static lease.

Is the "builtin" - dhcp server within the actual router?

For this specific test case,
here's the minimal working dhcpd config on the host machine,
runs side by side with the dhcpd on the actual router without problemos.

# yum install dhcp-server

# cat /etc/dhcp/dhcpd.conf
subnet 192.168.1.0 netmask 255.255.255.0
{
    option routers 192.168.1.2;
    option domain-name-servers 8.8.8.8;
}

host fedora-vm
{
    option host-name "fedora2364";
    hardware ethernet 52:54:00:12:34:56;
    fixed-address 192.168.1.99;
}

# systemctl start dhcpd.service

Of course, set the IP and MAC addresses given what is used there.

See is it gonna cause loss of desktop session, as here.

Tested with Fedora-Live-Xfce-x86_64-23-20150824.iso
Comment 13 Kevin Fenzi 2015-08-24 13:10:22 EDT
The lack of a login session in systemd-logind seems to be the issue here... 

When you see this could you do a: 

sudo journalctl -u systemd-logind -l 

and look for any errors? 

lightdm should have a session, then when you login it should show a session for your user being added.
Comment 14 poma 2015-08-24 16:31:25 EDT
For
$ journalctl --version | head -1
systemd 222

$ man 1 journalctl
...
The old options -l/--full are not useful anymore, except to undo --no-full.

also "sudo" is unnecessary
$ grep wheel /etc/group
wheel:x:10:liveuser

so you are probably thinking of
$ journalctl -u systemd-logind --no-pager

This is a Fedora 23, if you have not noticed.

First, will wait for confirmation of the bug from Wolfgang, if possible, then will deal with the rest.

In the meantime, you can test yourself.
Comment 15 Wolfgang Ulbrich 2015-08-24 20:00:42 EDT
Why did you re-asigng this to mate-session-manger?
As i mentioned before i don't see this issue.
Sorry, i use the builtin dhcp server from virtual-manager, v-m use as default virtual network (bridged) for VMs, and everything works well.
Maybe you have an issue with your dhcp config?
Did you ever test this on bare metal?

Again, i can't reproduce this with mate livecd!!!!!!!!!
Comment 16 Jirka Klimes 2015-08-25 04:08:24 EDT
I tried F23 Alpha live ISO - XFCE. The problem does not appear when booting, but it can be triggered by logging out and logging in again. Then the session goes to closing state and is not among ONLINE_SESSIONS any more. Even if loginctl lists it. (cat /run/systemd/users/1000)
Comment 17 Jirka Klimes 2015-08-25 04:09:56 EDT
Created attachment 1066771 [details]
session details when booting, and after log out/log in
Comment 18 poma 2015-08-25 05:11:26 EDT
True, it is one of the test scenarios to reproduce this specific bug(In reply to Jirka Klimes from comment #16)
> I tried F23 Alpha live ISO - XFCE. The problem does not appear when booting,
> but it can be triggered by logging out and logging in again. Then the
> session goes to closing state and is not among ONLINE_SESSIONS any more.
> Even if loginctl lists it. (cat /run/systemd/users/1000)

True, it is one of the test scenarios to reproduce this specific bug.
Actually it is more incompleteness of certain component caused by the "release rush", rather than common bug.

The common denominator for Xfce and MATE is LightDM.
Comment 20 poma 2015-08-25 08:44:23 EDT
1.10.4 release from the 1.10 series released 2014-11-13
1.10.5 release from the 1.10 series released 2015-03-10

lightdm-1.10.5-1.fc24
lightdm-1.10.4-8.fc23

Where is 1.10.5 for Fedora 23?
Comment 21 poma 2015-08-25 08:57:05 EDT
Besides, latest stable serie is 1.14
http://lists.freedesktop.org/archives/lightdm/2015-March/000776.html
Comment 22 Rex Dieter 2015-08-25 09:09:09 EDT
Besides... we've been over this before, fedora currently and purposely is tracking the lightdm-1.10.x LTS branch

1.10.5 builds are on the way
Comment 23 poma 2015-08-25 10:53:44 EDT
(In reply to Rex Dieter from comment #22)
> Besides... we've been over this before, fedora currently and purposely is
> tracking the lightdm-1.10.x LTS branch
> 

And ... you still have not understood.

https://getfedora.org/
Freedom. Friends. Features. First.

Long Term Support aka LTS is exactly the opposite of the First - Latest and Greatest.

Long Term Support aka LTS is concept characteristic to RHEL, Ubuntu X.Y.Z LTS or WhatNotLTS, but not to Fedora.

1.10.5, you really think this will help us.

Unlike Fedora, your motto looks like
Constipation. Insulation. Featureless. Antediluvian.
Comment 24 poma 2015-08-25 11:25:28 EDT
(In reply to poma from comment #23)
> (In reply to Rex Dieter from comment #22)
> > Besides... we've been over this before, fedora currently and purposely is
> > tracking the lightdm-1.10.x LTS branch
> > 
> 
> And ... you still have not understood.
> 
> https://getfedora.org/
> Freedom. Friends. Features. First.
> 
> Long Term Support aka LTS is exactly the opposite of the First - Latest and
> Greatest.
> 
> Long Term Support aka LTS is concept characteristic to RHEL, Ubuntu X.Y.Z
> LTS or WhatNotLTS, but not to Fedora.
> 
> 1.10.5, you really think this will help us.
> 
> Unlike Fedora, your motto looks like
> Constipation. Insulation. Featureless. Antediluvian.

Pardon me, your - as lightdm packager - motto looks like ...
what can not be said for Qt/KDE part of your maintenance.

Fascinating, isn't it.
Comment 25 Rex Dieter 2015-08-25 11:34:12 EDT
Sorry you feel that way, but I do not have an infinite amount of time.  I can only choose how to spend the time I have and I choose to focus it elsewhere.

See also previous comments that are still relevant:
https://bugzilla.redhat.com/show_bug.cgi?id=1091899#c17
https://bugzilla.redhat.com/show_bug.cgi?id=1091899#c19

I feel your mentioning it here (again), is not constructive or helpful.

What is constructive, I'm open to comaintainers to help.  Very much encourage it actually.

to repeat:
"You're welcome to help maintain lightdm, if you want to steer things in a different direction."
Comment 26 poma 2015-08-25 11:56:52 EDT
Same breakage with:
lightdm-1.10.5-1.fc23.x86_64
lightdm-gobject-1.10.5-1.fc23.x86_64
Comment 27 poma 2015-08-25 12:01:12 EDT
Has anyone read the reference I left?
If so, is it understandable what is written there?
Comment 28 Rex Dieter 2015-08-25 13:04:59 EDT
Your feedback about lack of a 1.10.5 update seemed to imply to me that you thought it would help.  Apparently that is not the case.

Re-reading the referenced upstream thread makes it look like this is still an unresolved issue, but it's not clear to me what should be fixed... lightdm or systemd.
Comment 29 poma 2015-08-25 14:14:44 EDT
It is a great explanation of the mechanism segment from Robert Ancell,
and it is not about the actual solution, but I think it was helpful in solving the problem.

If you go out of there toward "Previous message:" you'll find a reference to a discussion between 500 and dh.herrmann.
When and if you read the whole discussion, pay attention to the lightdm version used in all of the tests.

I do not know if you're aware, but upstream developers generally always ask and almost always expect the latest version or it could easily happen to put you on ignore.

Therefore, you will have to check yourself whether the current solution really applies to this ancient version of your.

--

I hope you understand now, at least a little bit more, why it is good to have Latest and Greatest.

BTW Ubuntu developers - lightdm and systemd - have missed this particular problem, just 500 caught it, haha.
At least they were honest and some thanked.

For the reference, what is used now:
lightdm-1.15.3-2.fc22.x86_64
lightdm-gtk-2.0.1-3.fc22.x86_64

>= lightdm 1.15.2 support Wayland sessions.
Comment 30 Wolfgang Ulbrich 2015-08-27 09:52:51 EDT
with Fedora-Live-MATE_Compiz-x86_64-23_Beta-TC1

After a logout/login of the liveuser the network connection is lost,
but i'm able to create a new one with normal dhcp server from virtual-manager.
For me it is acceptable to restart the live image to have again a network connection or create a new one, .... a livecd is an installer image and not for everyday usage.
Comment 31 poma 2015-08-27 13:11:29 EDT
Speaking of "Cutting off the Branch You're Sitting on".

Do you really think it's okay for Fedora to present itself with a broken functionality, whatever it is!?
Comment 32 poma 2015-08-27 13:15:10 EDT
Some people never learn.

BTW, Rex Dieter have you found the solution?
Comment 33 Wolfgang Ulbrich 2015-08-27 13:27:26 EDT
(In reply to poma from comment #31)
> Speaking of "Cutting off the Branch You're Sitting on".
> 
> Do you really think it's okay for Fedora to present itself with a broken
> functionality, whatever it is!?
No, but do you realy think this will fix?


(In reply to poma from comment #32)
> Some people never learn.
what's wrong with you?
...i'm out....no need to have your explosions in my mailbox :)
Comment 34 Rex Dieter 2015-08-27 14:15:02 EDT
Re: comment #32

Sorry, no solution from me.  I assure you, when/if I do, I'll report it here.
Comment 35 poma 2015-08-27 18:45:15 EDT
(In reply to Wolfgang Ulbrich from comment #33)
> (In reply to poma from comment #31)
> > Speaking of "Cutting off the Branch You're Sitting on".
> > 
> > Do you really think it's okay for Fedora to present itself with a broken
> > functionality, whatever it is!?
> No, but do you realy think this will fix?
> 

You think the fix is in the mix?

> 
> (In reply to poma from comment #32)
> > Some people never learn.
> what's wrong with you?

Maybe inspiring comments from you.
Running away, already?
Comment 36 poma 2015-08-27 18:48:57 EDT
(In reply to Rex Dieter from comment #34)
> Re: comment #32
> 
> Sorry, no solution from me.  I assure you, when/if I do, I'll report it here.

Good luck, man.
Comment 37 Wolfgang Ulbrich 2015-08-27 19:14:18 EDT
> Running away, already?

s.m.d
Comment 38 poma 2015-08-28 09:00:40 EDT
(In reply to Wolfgang Ulbrich from comment #37)
> > Running away, already?
> 
> s.m.d

Wolfgang Ulbrich, if you are afraid to write a full sentence, then you do not have anything to "suck".

I called you here - you as maintainer of MATE - to help us here,
not to play the "semi-retard" role.
Comment 39 Rex Dieter 2015-08-28 09:54:07 EDT
poma,   wolfgang tried to remove himself from the situation, and you keep re-adding him... what you are doing is hard to characterize as anything but harrassment at this point.  Please stop with any comments that are anything but adding technical details about the bug in question.

If in doubt, I encourage you to (re)read https://getfedora.org/code-of-conduct
Comment 40 poma 2015-08-28 11:27:12 EDT
(In reply to Rex Dieter from comment #39)
> poma,   wolfgang tried to remove himself from the situation, and you keep
> re-adding him... 

"remove himself from the situation" - what is that supposed to mean!?
BTW s.m.d aka "suck my dick" is a common greeting in Europe - If in doubt?

Your patronizing attempt is really pathetic, Rex Dieter.
Comment 41 poma 2015-08-28 11:29:29 EDT
Wolfgang Ulbrich, I expect from you a sincere apology.
Comment 42 Michael Schwendt 2015-08-28 11:37:04 EDT
poma, let it rest, please.

The ticket history is not on your side:
https://bugzilla.redhat.com/show_activity.cgi?id=1251027

What you've been trying will lead to nothing. You are in no position to force anyone, and readding people to Cc is just rude.

The damage is done. Consider starting with an apology yourself, and maybe that will fix things a bit, at least.
Comment 43 poma 2015-08-28 11:58:44 EDT
(In reply to Michael Schwendt (Fedora Packager Sponsors Group) from comment #42)
> poma, let it rest, please.
> 
> The ticket history is not on your side:
> https://bugzilla.redhat.com/show_activity.cgi?id=1251027
> 
> What you've been trying will lead to nothing. You are in no position to
> force anyone, and readding people to Cc is just rude.
> 
> The damage is done. Consider starting with an apology yourself, and maybe
> that will fix things a bit, at least.

Very funny from you, I have to admit.
Even you approve of this "European - If in doubt" greeting!?

BTW how are you, long time no see, maestro.

Note You need to log in before you can comment on or make changes to this bug.