Bug 1251042 - while re-configuring the scrubber frequency, scheduling is not happening based on current time
while re-configuring the scrubber frequency, scheduling is not happening base...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: bitrot (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kotresh HR
bugs@gluster.org
: Reopened, ZStream
Depends On: 1226995 1232307
Blocks: 1216951 1253160
  Show dependency treegraph
 
Reported: 2015-08-06 08:58 EDT by Kotresh HR
Modified: 2016-06-16 09:29 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1226995
: 1253160 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:29:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Kotresh HR 2015-08-06 08:59:21 EDT
Description of problem:
==============================
while re-configuring the scrubber frequency, scheduling is not happening based on current time 


Version-Release number of selected component (if applicable):
=====================
mainline



How reproducible:


Steps to Reproduce:
====================
1.Create a volume and enable bitrot
2.After some time change the scrubber frequency to hourly but scheduling is happening based on bitrot enable time of the volume not from current time
3.

Actual results:


Expected results:
=====================
while re-configuring the scrubber frequency, scheduling should happen based current time
Comment 2 Anand Avati 2015-08-06 09:02:18 EDT
REVIEW: http://review.gluster.org/11853 (features/bitrot: Fix rescheduling scrub-frequency) posted (#1) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 3 Anand Avati 2015-08-07 03:13:56 EDT
REVIEW: http://review.gluster.org/11853 (features/bitrot: Fix rescheduling scrub-frequency) posted (#2) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 4 Anand Avati 2015-08-13 01:38:16 EDT
COMMIT: http://review.gluster.org/11853 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 1d0968d5acd10188d4684bfb1d345c72ccefa75a
Author: Kotresh HR <khiremat@redhat.com>
Date:   Thu Aug 6 16:53:22 2015 +0530

    features/bitrot: Fix rescheduling scrub-frequency
    
    While rescheduling scrub frequency, boot time of
    the brick was considered where it is not required
    and also delta is calculated using unsigned int
    resulting in the loss of fractional part leading to
    wrong scrub frequency. Boot time is completely
    removed and delta calculation is simplified.
    
    Change-Id: If54697389f663afc86408dc8a01a3ea07e00f2dc
    BUG: 1251042
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/11853
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 5 Nagaprasad Sathyanarayana 2015-10-25 11:06:14 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 6 Niels de Vos 2016-06-16 09:29:42 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.