Bug 1253160 - while re-configuring the scrubber frequency, scheduling is not happening based on current time
while re-configuring the scrubber frequency, scheduling is not happening base...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: bitrot (Show other bugs)
3.7.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kotresh HR
bugs@gluster.org
: ZStream
Depends On: 1226995 1232307 1251042
Blocks: 1216951
  Show dependency treegraph
 
Reported: 2015-08-13 03:09 EDT by Kotresh HR
Modified: 2015-09-09 05:39 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1251042
Environment:
Last Closed: 2015-09-09 05:39:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kotresh HR 2015-08-13 03:09:10 EDT
+++ This bug was initially created as a clone of Bug #1251042 +++

+++ This bug was initially created as a clone of Bug #1226995 +++

Description of problem:
==============================
while re-configuring the scrubber frequency, scheduling is not happening based on current time 


Version-Release number of selected component (if applicable):
=====================


How reproducible:


Steps to Reproduce:
====================
1.Create a volume and enable bitrot
2.After some time change the scrubber frequency to hourly but scheduling is happening based on bitrot enable time of the volume not from current time
3.

Actual results:


Expected results:
=====================
while re-configuring the scrubber frequency, scheduling should happen based current time
Comment 1 Anand Avati 2015-08-13 03:14:52 EDT
REVIEW: http://review.gluster.org/11904 (features/bitrot: Fix rescheduling scrub-frequency) posted (#1) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)
Comment 2 Anand Avati 2015-08-24 00:37:00 EDT
COMMIT: http://review.gluster.org/11904 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit 1b603f17a75b4d41d8d7eb9d832321dd7387dd31
Author: Kotresh HR <khiremat@redhat.com>
Date:   Thu Aug 6 16:53:22 2015 +0530

    features/bitrot: Fix rescheduling scrub-frequency
    
    While rescheduling scrub frequency, boot time of
    the brick was considered where it is not required
    and also delta is calculated using unsigned int
    resulting in the loss of fractional part leading to
    wrong scrub frequency. Boot time is completely
    removed and delta calculation is simplified.
    
    BUG: 1253160
    Change-Id: I98dd1fa99304c6d91c0a330dfca7fef57a770397
    Reviewed-on: http://review.gluster.org/11853
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/11904
Comment 3 Kaushal 2015-09-09 05:39:37 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.