Bug 1251192 - rfe: please change gdm to not add :/bin:/sbin to $PATH
rfe: please change gdm to not add :/bin:/sbin to $PATH
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 12:23 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2015-08-06 21:03 EDT (History)
1 user (show)

See Also:
Fixed In Version: gdm-3.17.4-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-06 12:39:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2015-08-06 12:23:37 EDT
Description of problem:
gdm adds the "old school" dirs to the default $PATH for uses sessions. It's not harmful, but has some downsides:
- every path search is infinitesimally slower
- every execve strace log is longer
- anyone looking at $PATH has to think longer

Since the /usr split is long gone, please consider removing it also from the path.

Version-Release number of selected component (if applicable):
gdm-3.16.2-1.fc22.x86_64
Comment 1 Ray Strode [halfline] 2015-08-06 12:39:18 EDT
okay i added 

--with-default-path=/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin \

to the configure line

Note You need to log in before you can comment on or make changes to this bug.