Bug 1251320 - rfe: please change login to not add /bin:/sbin to $PATH
rfe: please change login to not add /bin:/sbin to $PATH
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 21:03 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2015-08-26 00:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.27-0.2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 05:01:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2015-08-06 21:03:28 EDT
Description of problem:
login adds the "old school" dirs to the default $PATH. It's not harmful, but has some downsides:
- every path search is infinitesimally slower
- every execve strace log is longer
- anyone looking at $PATH has to think longer

Since the /usr split is long gone, please consider removing it also from the path. gdm (which sets the paths for graphical user sessions, now uses to 
--with-default-path=/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin).

Version-Release number of selected component (if applicable):
[test@rawhide ~]$ rpm -qf /bin/login
util-linux-2.27-0.1.fc24.x86_64

[test@rawhide ~]$ strings /bin/login|grep :/bin
/usr/local/bin:/bin:/usr/bin
/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
Comment 1 Karel Zak 2015-08-12 04:46:50 EDT
Good point...
Comment 2 Karel Zak 2015-08-12 05:01:53 EDT
Fixed in f23 and rawhide.
Comment 3 Fedora Update System 2015-08-12 05:15:01 EDT
util-linux-2.27-0.2.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/util-linux-2.27-0.2.fc23
Comment 4 Fedora Update System 2015-08-26 00:34:05 EDT
util-linux-2.27-0.2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.