Bug 1251346 - statfs giving incorrect values for AFR arbiter volumes
statfs giving incorrect values for AFR arbiter volumes
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
: Reopened
Depends On:
Blocks: 1251380
  Show dependency treegraph
 
Reported: 2015-08-07 00:38 EDT by Ravishankar N
Modified: 2016-06-16 09:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1251380 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:29:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2015-08-07 00:38:19 EDT
Description of problem:

AFR serves statfs from the brick having the least free space available. Since the size to be allocated to the arbiter brick in a 3 way replica is supposed to be considerably lesser than the other 2 bricks, statfs will always be served from this brick which is incorrect.
Comment 1 Ravishankar N 2015-08-07 00:39:43 EDT
The problem was reported by Frederik Brandt on gluster-users: http://www.gluster.org/pipermail/gluster-users/2015-August/023026.html
Comment 2 Anand Avati 2015-08-07 01:01:58 EDT
REVIEW: http://review.gluster.org/11857 (afr: Do not wind statfs to arbiter brick) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 3 Anand Avati 2015-08-07 03:03:13 EDT
REVIEW: http://review.gluster.org/11857 (afr: Do not wind statfs to arbiter brick) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 4 Anand Avati 2015-08-07 07:49:59 EDT
COMMIT: http://review.gluster.org/11857 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 2a3f0fb035cf677d058a920d2fc1931a18e565ec
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Fri Aug 7 10:10:54 2015 +0530

    afr: Do not wind statfs to arbiter brick
    
    Problem: AFR serves statfs from the brick having the least free space
    available. Since the size to be allocated to the arbiter brick in a 3
    way replica is supposed to be considerably lesser than the other 2
    bricks, statfs will be served from this brick which is incorrect.
    
    Fix: Don't serve statfs from the arbiter brick.
    
    Change-Id: I5af098b9c50626f52cf3d7dbb060bf754c797f05
    BUG: 1251346
    Reported-by: Fredrik Brandt <fredrikb@denlillaplaneten.se>
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/11857
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 5 Anand Avati 2015-08-07 08:06:21 EDT
REVIEW: http://review.gluster.org/11864 (tests: add basic/afr/arbiter-statfs.t) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 6 Ravishankar N 2015-08-07 08:09:25 EDT
ToDo: Move BZ state to MODIFIED after patch in comment #5 gets merged.
Comment 7 Anand Avati 2015-08-07 08:36:26 EDT
REVIEW: http://review.gluster.org/11864 (tests: add basic/afr/arbiter-statfs.t) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 8 Anand Avati 2015-08-10 20:23:45 EDT
REVIEW: http://review.gluster.org/11864 (tests: add basic/afr/arbiter-statfs.t) posted (#4) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 9 Anand Avati 2015-08-11 09:35:27 EDT
COMMIT: http://review.gluster.org/11864 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit f550efa2879c02dec4c8f6876a94fcfd95b5bf91
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Fri Aug 7 17:32:29 2015 +0530

    tests: add basic/afr/arbiter-statfs.t
    
    This is a test-case for BZ 1251346
    
    Change-Id: Icbde8d17c823a3f2c98056c14a75f0ef5227b848
    BUG: 1251346
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/11864
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 10 Vijay Bellur 2015-09-02 17:06:07 EDT
REVIEW: http://review.gluster.org/12094 (tests: Parsing df output isn't reliable, use stat -f) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 11 Vijay Bellur 2015-09-03 02:38:41 EDT
REVIEW: http://review.gluster.org/12096 (tests: check free space only on gluster mount) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 12 Vijay Bellur 2015-09-03 03:05:39 EDT
REVIEW: http://review.gluster.org/12096 (tests: check free space only on gluster mount) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 13 Vijay Bellur 2015-09-04 00:38:32 EDT
COMMIT: http://review.gluster.org/12096 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit 378b625698fe01ed2c3a6f4f065a699b2d573947
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Thu Sep 3 12:05:12 2015 +0530

    tests: check free space only on gluster mount
    
    Change-Id: I06de4f555e66fac2594676572c8f8a4ee08f8131
    BUG: 1251346
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/12096
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 14 Nagaprasad Sathyanarayana 2015-10-25 11:21:35 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 15 Niels de Vos 2016-06-16 09:29:42 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.