Bug 1251380 - statfs giving incorrect values for AFR arbiter volumes
statfs giving incorrect values for AFR arbiter volumes
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
:
Depends On: 1251346
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 03:24 EDT by Ravishankar N
Modified: 2015-09-09 05:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1251346
Environment:
Last Closed: 2015-09-09 05:39:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2015-08-07 03:24:23 EDT
+++ This bug was initially created as a clone of Bug #1251346 +++

Description of problem:

AFR serves statfs from the brick having the least free space available. Since the size to be allocated to the arbiter brick in a 3 way replica is supposed to be considerably lesser than the other 2 bricks, statfs will always be served from this brick which is incorrect.

--- Additional comment from Ravishankar N on 2015-08-07 00:39:43 EDT ---

The problem was reported by Frederik Brandt on gluster-users: http://www.gluster.org/pipermail/gluster-users/2015-August/023026.html

--- Additional comment from Anand Avati on 2015-08-07 01:01:58 EDT ---

REVIEW: http://review.gluster.org/11857 (afr: Do not wind statfs to arbiter brick) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Anand Avati on 2015-08-07 03:03:13 EDT ---

REVIEW: http://review.gluster.org/11857 (afr: Do not wind statfs to arbiter brick) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 1 Anand Avati 2015-08-07 03:25:43 EDT
REVIEW: http://review.gluster.org/11858 (afr: Do not wind statfs to arbiter brick) posted (#1) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)
Comment 2 Anand Avati 2015-08-12 08:35:11 EDT
COMMIT: http://review.gluster.org/11858 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit b95d40bfd760525f0c3e1cf0a11a8087c17a7110
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Fri Aug 7 12:52:23 2015 +0530

    afr: Do not wind statfs to arbiter brick
    
    Backport of: http://review.gluster.org/#/c/11857/
    
    Problem: AFR serves statfs from the brick having the least free space
    available. Since the size to be allocated to the arbiter brick in a 3
    way replica is supposed to be considerably lesser than the other 2
    bricks, statfs will be served from this brick which is incorrect.
    
    Fix: Don't serve statfs from the arbiter brick.
    
    Change-Id: Ia2d2402ba1e8f5d96831f71b3f8337f241e6753b
    BUG: 1251380
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/11858
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 3 Anand Avati 2015-08-12 08:46:06 EDT
REVIEW: http://review.gluster.org/11900 (tests: add basic/afr/arbiter-statfs.t) posted (#1) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)
Comment 4 Kaushal 2015-09-09 05:39:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.