Bug 1251447 - posix_make_ancestryfromgfid doesn't set op_errno
posix_make_ancestryfromgfid doesn't set op_errno
Status: CLOSED DUPLICATE of bug 1229621
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
storage-qa-internal@redhat.com
: ZStream
Depends On:
Blocks: 1251449 1253260
  Show dependency treegraph
 
Reported: 2015-08-07 06:10 EDT by Vijaikumar Mallikarjuna
Modified: 2016-09-17 08:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1251449 (view as bug list)
Environment:
Last Closed: 2015-08-07 07:13:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-08-07 06:10:25 EDT
Lot of below errors seeing with a community user setup:

[2015-08-04 22:33:43.001231] E [MSGID: 113104] [posix-handle.c:154:posix_make_ancestryfromgfid] 0-vol_home-posix: could not read the link from the gfid handle /export/brick_home/brick1/data/.glusterfs/3b/33/3b336a89-9506-44bf-a339-0d446e3a79b0  [Aucun fichier ou dossier de ce type]
[2015-08-04 22:33:43.003845] E [MSGID: 113104] [posix-handle.c:154:posix_make_ancestryfromgfid] 0-vol_home-posix: could not read the link from the gfid handle /export/brick_home/brick1/data/.glusterfs/81/5a/815acde3-7f47-410b-9131-e8d75c71a5bd  [Aucun fichier ou dossier de ce type]




ENOENT/ESTALE errors should not be printed
Also posix_make_ancestryfromgfid is not setting errno
Comment 2 Vijaikumar Mallikarjuna 2015-08-07 07:13:12 EDT

*** This bug has been marked as a duplicate of bug 1229621 ***

Note You need to log in before you can comment on or make changes to this bug.